POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun【记忆化递归】

509 篇文章 9 订阅
232 篇文章 0 订阅

Function Run Fun

Description

We all love recursion! Don’t we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source

Pacific Northwest 1999

问题链接POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun
问题描述:(略)
问题分析
    这是一个递归函数计算问题,最怕的是重复计算。
    该题的绝大多数解法是打表法,然而递归函数计算可以采用记忆化递归进行计算。打表法则需要事先把所有的可能都算出来;记忆化递归也打表,但只计算必要的项,有可能计算量更少一些。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun */

#include <stdio.h>
#include <string.h>

#define N 20
int f[N + 1][N + 1][N + 1];

int w(int a, int b, int c)
{
    if(a <= 0 || b <= 0 || c <= 0) return 1;
    else if(a > N || b > N || c > N) return w(N, N, N);
    else if(f[a][b][c]) return f[a][b][c];
    else if(a < b && b < c) return f[a][b][c] = w(a, b, c - 1) + w(a, b - 1, c - 1) - w(a, b - 1, c);
    else return f[a][b][c] = w(a - 1, b, c) + w(a - 1, b - 1, c) + w(a - 1, b, c - 1) - w(a - 1, b - 1, c - 1);
}

int main(void)
{
    memset(f, 0, sizeof(f));

    int a, b, c;
    while(scanf("%d%d%d", &a, &b, &c) != EOF) {
        if(a == -1 && b == -1 && c == -1) return 0;
        printf("w(%d, %d, %d) = %d\n", a, b, c, w(a,b,c));
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值