UVA550 UVALive5566 Multiplying by Rotation【进制+迭代】

Warning: Not all numbers in this problem are decimal numbers!
Multiplication of natural numbers in general is a cumbersome operation. In some cases however the product can be obtained by moving the last digit to the front.
    Example: 179487 * 4 = 717948
    Of course this property depends on the numbersystem you use, in the above example we used the decimal representation. In base 9 we have a shorter example:
    17 * 4 = 71 (base 9)
as (9 * 1 + 7) * 4 = 7 * 9 + 1
Input
The input for your program is a textfile. Each line consists of three numbers separated by a space: the base of the number system, the least significant digit of the first factor, and the second factor. This second factor is one digit only hence less than the base. The input file ends with the standard end-of-file marker.
Output
Your program determines for each input line the number of digits of the smallest first factor with the rotamultproperty. The output-file is also a textfile. Each line contains the answer for the corresponding input line.
Sample Input
10 7 4
9 7 4
17 14 12
Sample Output
6
2
4

问题链接UVA550 UVALive5566 Multiplying by Rotation
问题简述
    一个数乘以基数,等于原来数的最低位移到最高位。求这样的数最多有几位?给定基数、尾数(最低位)和因子。
问题分析
    进制问题,通过迭代计算解决。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA550 UVALive5566 Multiplying by Rotation */

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int base, last, factor;
    while(scanf("%d%d%d", &base, &last, &factor)!=EOF) {
        int cnt = 1, tmp = factor * last;
        while(last != tmp) {
            tmp = tmp % base * factor + tmp / base;
            cnt++;
        }

        printf("%d\n", cnt);
    }

    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值