UVA11121 Base -2【-2进制】

The creator of the universe works in mysterious ways.

But he uses a base ten counting system and likes round numbers.

**Scott Adams**

Everyone knows about base 2 (binary) integers and base 10 (decimal) integers, but what about base -2? An integer n written in base -2 is a sequence of digits (bi), writen right-to-left. Each of which is either 0 or 1 (no negative digits!), and the following equality must hold.

n = b0 + b1(−2) + b2(−2)2 + b3(−2)3 + . . .

    The cool thing is that every integer (including the negative ones) has a unique base-2 representation, with no minus sign required. Your task is to find this representation.
Input
The first line of input gives the number of cases, N (at most 10000). N test cases follow. Each one is a line containing a decimal integer in the range from -1,000,000,000 to 1,000,000,000.
Output
For each test case, output one line containing ‘Case #x:’ followed by the same integer, written in base -2 with no leading zeros.
Sample Input
4
1
7
-2
0
Sample Output
Case #1: 1
Case #2: 11011
Case #3: 10
Case #4: 0

问题链接UVA11121 Base -2
问题简述:(略)
问题分析
    -2进制问题。给定10进制数n,将其转换为-2进制。
    需要注意特殊情况,例如n=0时处理。每次用-2作为除数进行取余运算,如果得到-1则需要特殊处理。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++程序如下:

/* UVA11121 Base -2 */

#include <bits/stdc++.h>

using namespace std;

const int BASE = -2;
const int N = 200;
int ans[N], cnt, digit;

int main()
{  
    int t, n, caseno = 0;
    scanf("%d", &t);
    while (t --) {
        scanf("%d", &n);
        cnt = 0;
        if (n == 0)
            ans[cnt++] = 0;
        while (n) {
            digit = n % BASE;
            if (digit == -1)
                digit = 1;
            n = (n - digit) / BASE;
            ans[cnt ++] = digit;
        }

        printf("Case #%d: ", ++caseno);
        for (int i = cnt - 1; i >= 0; i --)
            printf("%d", ans[i]);
        printf("\n");
    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值