UVa 524 Prime Ring Problem(回溯)

传送门

A ring is composed of n (even number) circles as shown in diagram.
Put natural numbers 1, 2, . . . , n into each circle separately, and the
sum of numbers in two adjacent circles should be a prime.
Note: the number of first circle should always be 1.
Input
n (0 < n ≤ 16)
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the
ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above
requirements.
You are to write a program that completes above process.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
这里写图片描述
这道题比较近坑的一点就是格式,正确的格式应该是这样的:
这里写图片描述
方法是回溯,从1开始往后搜,只要相邻两数之和为素数就继续向前搜,搜到两数之和部位素数后者到达边界为止。
小技巧:

  • 奇数数不能形成素数环的,因为这种情况必存在两个奇数相邻他们的和为偶数,所以只对偶数情况搜索
  • 题目数据量不大,能形成的最大素数16+15=31,所以可以直接列出需要的素数然后二分查找
  • (打表是最骚的)
    代码:
#include <bits/stdc++.h>
using namespace std;
int prime[10] = {3,5,7,11,13,17,19,23,29,31};
int ring[17]= {1};
bool vis[17];
bool isPrime(int n)
{
    int left = 0,right = 9;
    while(left<=right)
    {
        int mid = (left+right)/2;
        if(prime[mid]==n)
            return true;
        else if(prime[mid]<n)
            left = mid+1;
        else
            right = mid-1;
    }
    return false;
}
void DFS(int cur,int n)
{
    if(cur==n&&isPrime(ring[0]+ring[n-1]))
        for(int i=0; i<n; i++)
            i?i==n-1?
            printf(" %d\n",ring[n-1]):
            printf(" %d",ring[i]):
            printf("%d",ring[i]);
    else
        for(int i=2; i<=n; i++)
        {
            if(!vis[i]&&isPrime(i+ring[cur-1]))
            {
                ring[cur] = i;
                vis[i] = true;
                DFS(cur+1,n);
                vis[i] = false;
            }
        }
        return;
}
int main()
{
    int n,ring[99],cnt = 0;
    while(~scanf("%d",&n))
    {
        if(cnt)
            puts("");
        printf("Case %d:\n",++cnt);
        if(n%2)
            continue;
        else
            DFS(1,n);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值