A+B for Input-Output Practice (VIII) --JAVA

题目:

Your task is to calculate the sum of some integers. 

Input

Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 

Output

For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs. 

Sample Input

3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output

10

15

6

题意:

给你一个n,代表有n组测试数据,然后后面的n行,每一行的第一个数字m代表要求后面的m个数字的和;

格式需要注意,每两个结果之间有一个空行。

代码如下:

JAVA:

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner input=new Scanner(System.in);
	int n,m,a,s;
	n=input.nextInt();
	while(n-->0) {
		m=input.nextInt();
		s=0;
		for(int i=0;i<m;i++) {
			a=input.nextInt();
			s=s+a;
		}
		System.out.println(s);
		if(n!=0)
		System.out.println();
	}
}
}

C++:

#include<stdio.h>
int main()
{
   int N;
   scanf("%d",&N);
   while(N--)
   {
       int i,M,n,sum=0;
       scanf("%d",&M);
       for(i=0;i<M;i++)
       {
           scanf("%d",&n);
           sum=sum+n;
       }
       printf("%d\n",sum);
       if(N!=0)
        printf("\n");
   }
  return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值