[1096]:A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 124145 Accepted Submission(s): 37912

Problem Description
Your task is to calculate the sum of some integers.

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

#include<stdio.h>

int main()
{
    int i, j, count;
    while(scanf("%d", &count)!=EOF){
        while(count--){
            scanf("%d", &i);
            int sum = 0, str[100];
            for(j=0; j<i; j++){
                scanf("%d", &str[j]);
                sum += str[j];
            }
            if(count>0){
                printf("%d\n\n", sum);
            }
            else{
                printf("%d\n", sum);
            }
        }
    }
    return 0;
}

这里写图片描述

A+B的这几种类型题都是比较简单的,可以作为ACM入门的练手题(学习一下格式等等)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值