(甲)1019 General Palindromic Number (20 分)

题目:

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0N > 0N>0 in base b≥2b \ge 2b≥2, where it is written in standard notation with k+1k+1k+1 digits aia_ia​i​​ as ∑i=0k(aibi)\sum_{i=0}^k (a_ib^i)∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤ai<b0 \le a_i < b0≤a​i​​<b for all iii and aka_ka​k​​ is non-zero. Then NNN is palindromic if and only if ai=ak−ia_i = a_{k-i}a​i​​=a​k−i​​ for all iii. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer NNN and a base bbb, you are supposed to tell if NNN is a palindromic number in base bbb.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers NNN and bbb, where 0<N≤1090 < N \le 10^90<N≤10​9​​ is the decimal number and 2≤b≤1092 \le b \le 10^92≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if NNN is a palindromic number in base bbb, or No if not. Then in the next line, print NNN as the number in base bbb in the form "aka_ka​k​​ak−1a_{k-1}a​k−1​​ ... a0a_0a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

题意:

给你两个数N和K,问你数字N在K进制下是否是回文数字;如果是,输出Yes,否则输出No;输出转换进制后的数字,注意输出格式;

思路:

先转换进制;然后判断是否是回文数字;输出;

代码如下:

#include<stdio.h>
#include<string.h>

int n,k;
int a[1001];

int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        int m=n;
        int t=0;
        while(m!=0)//转换进制;
        {
            a[t++]=m%k;
            m=m/k;
        }
        int flag=0;
        for(int i=0,j=t-1;i<t,j>i;i++,j--)//判断是否是回文数字;
        {
            if(a[i]!=a[j])
            {
                flag=1;
                break;
            }
        }
        if(flag==0)//注意输出格式;
            printf("Yes\n");
        else
            printf("No\n");
        for(int i=t-1;i>0;i--)
            printf("%d ",a[i]);
        printf("%d\n",a[0]);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值