1007 Maximum Subsequence Sum (25分)

1007 Maximum Subsequence Sum (25分)

Input Specification:
Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:
For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

思路:设置两个指针,分别指向首尾,设置两个数来记录,一个记录最大值,一个记录当前值,当前值不断加后面一位。如果当前值大于最大值,进行替换,并把尾指针移到当前位置。如果当前值小于0,就清零,因为负数加任何数都小于本身。此时把首指针移到前面。最后判断首尾指针位置,如果尾指针在首指针前面,再通过尾指针倒推。

注意的坑:
例:0 -1 -2
输出:0 0 0
所以一开始首位指针都定点。

#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<vector>
#include<queue>
#include <cstring>
using namespace std;

#define _for(i,a,b) for(int i=(a);i<=(b);i++)


int main()
{
  int i,n,max,now,p1,p2;
  cin>>n;
  int num[n];
  _for(i,0,n-1){
     cin>>num[i];
  }
  int flag=0;
   _for(i,0,n-1){
   //排除全为负数情况
     if(num[i]>=0)
     {
        max=now=num[i];
        p1=p2=i;
        //注意首尾指针一起定位
        flag++;
        break;
     }
  }
  if(flag==0)
  {
    cout<<0<<" "<<num[0]<<" "<<num[n-1];
    return 0;
  }
  _for(i,p1+1,n-1){
  //注意从首指针后面开始加起
    now+=num[i];
    if(now>max)
    {
        max=now;
        p2=i;
    }
    if(now<0)
    {
      now=0;
      p1=i+1;
    }
  }
  if(p2>p1)
  {
    cout<<max<<" "<<num[p1]<<" "<<num[p2];
    return 0;
  }
  else{
    now=max;
      for(int i=p2;i>=0;i--){
          now-=num[i];
          if(now==0)
          {
             p1=i;
          }
      }
      cout<<max<<" "<<num[p1]<<" "<<num[p2];
    return 0;
  }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值