hdu-1200 To and Fro

To and Fro

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6243    Accepted Submission(s): 4288


Problem Description
Mo and Larry have devised a way of encrypting messages. They first decide secretly on the number of columns and write the message (letters only) down the columns, padding with extra random letters so as to make a rectangular array of letters. For example, if the message is “There’s no place like home on a snowy night” and there are five columns, Mo would write down

t o i o y
h p k n n
e l e a i
r a h s g
e c o n h
s e m o t
n l e w x


Note that Mo includes only letters and writes them all in lower case. In this example, Mo used the character ‘x’ to pad the message out to make a rectangle, although he could have used any letter.

Mo then sends the message to Larry by writing the letters in each row, alternating left-to-right and right-to-left. So, the above would be encrypted as

toioynnkpheleaigshareconhtomesnlewx

Your job is to recover for Larry the original message (along with any extra padding letters) from the encrypted one.
 

Input
There will be multiple input sets. Input for each set will consist of two lines. The first line will contain an integer in the range 2. . . 20 indicating the number of columns used. The next line is a string of up to 200 lower case letters. The last input set is followed by a line containing a single 0, indicating end of input.
 

Output
Each input set should generate one line of output, giving the original plaintext message, with no spaces.
 

Sample Input
  
  
5 toioynnkpheleaigshareconhtomesnlewx 3 ttyohhieneesiaabss 0
 

Sample Output
  
  
theresnoplacelikehomeonasnowynightx thisistheeasyoneab
题目给的例子和第一组数据的内容要仔细看好了,并不是直接将字符串输入就可以处理了,题目中构成的矩形元素是蛇形保存的,也就是说输入abc abc,保存为题中的矩形就是abc cba,注意好这点,这题就可以根据前一个元素与后一个元素索引相差为列数来寻找正确的密码了。代码如下:
//
//  main.cpp
//  hdu1200
//
//  Created by Morris on 16/7/15.
//  Copyright © 2016年 Morris. All rights reserved.
//

#include <cstdio> 
#include <cstring> 
#include <algorithm>

namespace {
    using std::scanf;
    using std::printf;
    using std::strlen;
    using std::reverse;
}

int main(int argc, const char *argv[])
{
    int len;
    int col;
    int row;
    char rec[300];
    char res[300];
    while (scanf("%d", &col) && col != 0) {
        scanf("%s", rec);
        len = (int) strlen(rec);
        row = len / col;
        
        int i;
        for (i = 0; i < row; ++i) {
            if (i % 2 != 0) {
                reverse(std::begin(rec) + i * col, std::begin(rec) + (i + 1) * col);
            }
        }
        
        int j;
        int k = 0;
        for (i = 0; i < col; ++i) {
            for (j = i; j <= i + col * (row - 1); j += col) {
                res[k++] = rec[j];
            }
        }
        res[k] = '\0';
        
        printf("%s\n", res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值