POJ 1094 Sorting It All Out拓扑排序例题

13 篇文章 0 订阅
8 篇文章 3 订阅

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K

Description
An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input
Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output
For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.

Sample Input
4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output
Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
题意:输入n代表26个大写字母中的前n个参与,有m个关系
分出三种情况:
1.有环,不能确定拓扑序列
2.无环,能确定拓扑序列,但序列不唯一,是由于由于关系不够造成的
3.能确定唯一拓扑序列
思路:
1 就是题目要求的知道是第几个确定的结果,因此每个关系都要进行拓扑排序。
2.若有环的出现,那么最后的字符串肯定没有环中的字母,那么字符串个数就肯定小于n。
3.如果一个队列里面的元素超过1的话,就说明拓扑序列当前可以有多个起点,那么拓扑序列就是不唯一的

#include<iostream>
#include<string>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;
const int Max=10000;
int n,m;
string s[Max],t;
vector<int>G[Max];//邻接表
int indeg[Max];//入度
int tp()
{
    queue<int>que;
    int book=0;
    for(int i=0;i<n;i++)
    {
        if(indeg[i]==0)
            que.push(i);
    }
    int indeg2[Max];
    memcpy(indeg2,indeg,sizeof indeg);
    while(!que.empty())
    {
        if(que.size()>1)book=1;
        int now=que.front();
        que.pop();
        t+=now+'A';
        int SIZE=G[now].size();
        for(int i=0;i<SIZE;i++)
        {
            int to=G[now][i];
            --indeg2[to];
            if(indeg2[to]==0)
            {
                que.push(to);
            }
        }
    }
    if(t.size()<n)return -1;
    else if(book)return 0;
    else return 1;
}
int main()
{
    while(cin>>n>>m&&(n||m))
    {
        memset(indeg,0,sizeof indeg);
        for(int i=0;i<Max;i++)
        {
            G[i].clear();
        }
        for(int i=1;i<=m;i++)
        {
            cin>>s[i];
        }
        int id;
        int flag=1;
        for(int i=1;i<=m;i++)
        {
            t="";
            int x=s[i][0]-'A',y=s[i][2]-'A';
            ++indeg[y];
            G[x].push_back(y);
            flag=tp();
            if(flag==-1)
            {
                cout<<"Inconsistency found after "<<i<<" relations."<<endl;
                break;
            }
            else if(flag==1)
            {
                cout<<"Sorted sequence determined after "<<i<<" relations: "<<t<<"."<<endl;
                break;
            }
        }
        if(flag==0)cout<<"Sorted sequence cannot be determined."<<endl;
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值