1013 of greedy strategy

Problem Description
Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
 

Input
Input is a sequence of lines, each containing two positive integers s and d.
 

Output
For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
 

Sample Input
  
  
59 237 375 743 200000 849694 2500000 8000000
 

Sample Output
  
  
116 28 300612 Deficit
 
题目要求:公司数据损失只知道一年中8次汇报5次都是亏损,每月盈利或亏损的金额已经给出,算出一年中的最大利润,否者输出Deficit。
思路:分5种情况进行讨论:1若亏损都小于4倍盈利直接输出亏损,则一年2月亏10月赚;若2倍的亏损大于3倍的盈利,则一年4月亏8月赚:若三倍的亏损大于两倍的盈利,则一年6月亏6月赚;若4倍的亏损大于盈利,则10月亏2月赢;否者输出deficit。求出的和大于0输出否者输出deficit。
#include<cstdio>
#include<iostream>
using namespace std;
int main()
{
    int a,b,sum;
    while(scanf("%d%d",&a,&b)==2)
    {
        if(4*a<b)sum=10*a-2*b;
        else if(3*a<2*b)sum=8*a-4*b;
        else if(2*a<3*b)sum=6*a-6*b;
        else if(a<4*b)sum=3*a-9*b;
        else sum=-1;
        if(sum>0)printf("%d\n",sum);
        else printf("Deficit\n");

    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值