1012 of search

Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 64   Accepted Submission(s) : 18
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M &lt;= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.<br><br>Angel's friends want to save Angel. Their task is: approach Angel. We assume that &quot;approach Angel&quot; is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.<br><br>You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)<br>
 

Input
First line contains two integers stand for N and M.<br><br>Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. <br><br>Process to the end of the file.<br>
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." <br>
 

Sample Input
  
  
7 8<br>#.#####.<br>#.a#..r.<br>#..#x...<br>..#..#.#<br>#...##..<br>.#......<br>........<br>
 

Sample Output
  
  
13<br>
 

Author
CHEN, Xue
 

Source
ZOJ Monthly, October 2003
题目思路:天使被困需要营救,但在地图上既有墙又有警卫,所以要算出最短时间。
解题思路:天使可能有多个朋友,若正向通过结算所有朋友的最短时间进行判断最小值过程繁琐,但可以通过天使进行找朋友,这有只需要bfs一次即可,在基础的bfs中添加如果是警卫则时间加一,还有可以用优先队列进行优化,让时间少的靠前。
小技巧:可以不用visit数组记录,直接将做过的位置记录为墙,其实大部分这样的搜索题都可以这样做。
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>

#include<queue>
#include<iomanip>
using namespace std;
struct paopao
{
    int x,y;
    int count;
    friend bool operator<(paopao n1,paopao n2)
    {
        return n1.count>n2.count;
    }
};


   char map[1000][1000];
   int maxdd=0;
   int n,m;
   int  pao(int x,int y , int t, int m )
   {
       priority_queue<paopao> l;
        paopao pp;
        pp.x=t;
        pp.y=m;
        pp.count =0;
        l.push(pp);
       int ss[4]={0,0,-1,1};
       int ph[4]={1,-1,0,0};
       while(!l.empty())
       {
           pp=l.top();
           l.pop();
           if(pp.x==x&&pp.y==y)
           {
               return pp.count;
           }
           int i;
           paopao n2;
           for(i=0;i<=3;i++)
           {
               n2.x=pp.x+ss[i];
               n2.y=pp.y+ph[i];
               if(map[n2.x][n2.y]=='x')
               {
                   n2.count=pp.count+2;
               }
               else
               {
                   n2.count=pp.count+1;
               }
               if(map[n2.x][n2.y]!='#'&&n2.x>=1&&n2.x<=n&&n2.y>=1&&n2.y<=m)
               { map[n2.x][n2.y]='#';

                   l.push(n2);
               }
           }
       }
       return -1;
   }
int main()
{


  int i,j;
  paopao s;
  int ax,ay,rx,ry;
  while(cin>>n>>m)
    {
        for(i=1;i<=n;i++)
        {
          for(j=1;j<=m;j++)
          {
              cin>>map[i][j];

               if(map[i][j]=='a') {ax=i;ay=j;}
                if(map[i][j]=='r') {rx=i;ry=j;}


             if(map[i][j]=='r')
             {
                 s.x=i;
                 s.y=j;
                 s.count=0;


             }
          }
        }

       maxdd= pao(ax,ay,rx,ry);
       if(maxdd!=-1)
        cout<<maxdd<<endl;
        else
     cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值