PAT (Advanced Level) 1045. Favorite Color Stripe (30) LCS变种,动态规划

Eva想从给定的颜色条带中保留最喜欢的颜色,使用动态规划寻找剩余最喜欢颜色条带的最大长度。输入包含颜色总数、Eva喜欢的颜色顺序及原始条带,输出最佳结果的最大长度。
摘要由CSDN通过智能技术生成

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:
6
5 2 3 1 5 6
12 2 2 4 1 5 5 6 3 1 1 5 6
Sample Output:
7
看了一下算法导论,动态规划求X(ABCBDAB)与Y(BDCABA)的最长公共子串LCS。数学模型如下:
设c[i][j]表示Xi与Yj的LCS,若i==0,则c[i][j]=c[0][j-1],若j==0,则c[i][j]=c[i-1][0];
若x[i]==y[j],则c[i][j]=c[i-1][j-1]+1;
若x[i]!=y[j],则c[i][j]=max(c[i-1][j],c[i][j-1])。
 
本题与LCS相比,唯一的差别在于最长公共子串的字符可以连续出现。故我们在x[i]==y[j],即串尾匹配时,不应像LCS那样c[i][j]=c[i-1][j-1]+1,因为这样表明串尾字符不能参与前面的匹配了,即同一个字符不能连续进行匹配。应该c[i][j]=max(c[i-1][j],c[i][j-1])+1,x[i]和y[j]依然可以参与前面的匹配。
/*2015.7.25cyq*/
#include <iostream>
#include <vector>
#include <string>
#include <fstream>
using namespace std;

//ifstream fin("case1.txt");
//#define cin fin

int main(){
	int N;
	cin>>N;
	int n;
	cin>>n;
	vector<int> a(n);
	for(int i=0;i<n;i++)
		cin>>a[i];
	int m;
	cin>>m;
	vector<int> b(m);
	for(int i=0;i<m;i++)
		cin>>b[i];

	vector<vector<int> > c(n+1,vector<int>(m+1,0));
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			if(a[i-1]==b[j-1])//串尾相等
				c[i][j]=max(c[i-1][j],c[i][j-1])+1;//对于LCS,此处是c[i][j]=c[i-1][j-1]+1
			else
				c[i][j]=max(c[i-1][j],c[i][j-1]);
		}
	}
	cout<<c[n][m];

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值