文章标题

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19461 Accepted: 8670
Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output

3
Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.
Source

USACO 2007 Open Gold

上个周做连通图是用缩点,这题是恰恰相反,是拆点,妙哉,把一个牛拆成两个点,牛左,牛右,于是就有:源点→食物→牛左→牛右→饮料→汇点 每条边的容量都是1,因为只有一份食物和饮料,然后跑EK就可以了(模板是找的)

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXNODE = 800;
const int MAXEDGE = 100010;
typedef int Type;
const Type INF = 0x3f3f3f3f;

struct Edge{
    int u, v, next;
    Type cap, flow;  //容量 流量;
    Edge() {}
    Edge(int u, int v, Type cap, Type flow, int next): u(u), v(v), cap(cap), flow(flow), next(next){}
};

struct EK{
    int n, m, s, t;
    Edge edges[MAXEDGE];
    int head[MAXNODE], pre[MAXNODE];
    bool vis[MAXNODE];
    vector<int> cut;

    void init(int n) {
        this->n = n;
        memset(head, -1, sizeof(head));
        m = 0;
    }

    void AddEdge(int u, int v, Type cap) {
        edges[m] = Edge(u, v, cap, 0, head[u]);
        head[u] = m++;
        edges[m] = Edge(v, u, 0, 0, head[v]);
        head[v] = m++;
    }

    //通过BFS构建层次图,并在层次图中找到增广路
    bool BFS() {
        queue<int> Q;
        memset(vis, 0, sizeof(vis));
        vis[s] = 1;
        Q.push(s);

        while (!Q.empty()) {
            int u = Q.front(); Q.pop();

            for (int i = head[u]; ~i; i = edges[i].next) {
                Edge &e = edges[i];
                if (!vis[e.v] && e.cap > e.flow) {
                    vis[e.v] = true;
                    pre[e.v] = i;
                    if (e.v == t)
                        return true;
                    Q.push(e.v);
                }
            }
        }
        return false;
    }

    //增广,并修改每条边的流量
    Type Augment() {
        int u = t;
        Type flow = INF;
        while (u != s) {
            Edge &e = edges[pre[u]];
            flow = min(flow, e.cap - e.flow);
            u = e.u;
        }

        u = t;
        while (u != s) {
            edges[pre[u]].flow += flow;
            edges[pre[u] ^ 1].flow -= flow;
            u = edges[pre[u]].u;
        }
        return flow;
    }

    Type Maxflow(int s, int t) {
        this->s = s; this->t = t;
        Type flow = 0;

        while (BFS()) flow += Augment();
        return flow;
    }

    void Mincut() {
        cut.clear();
        for (int i = 0; i < m; i += 2)
            if (vis[edges[i].u] && !vis[edges[i].v] && edges[i].cap)
                cut.push_back(i);

    }
}ek;

int main()
{
    int n,f,d;
    int a,b,c;
    while(scanf("%d%d%d",&n,&f,&d)==3)
    {
        ek.init(2*n+f+d+1);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=0;j<a;j++)
            {
                scanf("%d",&c);
                ek.AddEdge(c,2*i-1+d+f,1);
            }
            ek.AddEdge(2*i-1+d+f,2*i+d+f,1);
            for(int j=0;j<b;j++)
            {
                scanf("%d",&c);
                ek.AddEdge(2*i+d+f,c+f,1);
            }
        }
        for(int i=1;i<=f;i++)
        {
            ek.AddEdge(0,i,1);
        }
        for(int i=f+1;i<=f+d;i++)
        {
            ek.AddEdge(i,2*n+f+d+1,1);
        }
        int ans=ek.Maxflow(0,2*n+d+f+1);
            printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值