poj1562 Oil Deposits(dfs求联通分量)

                                                                      Oil Deposits
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11399 Accepted: 6199

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2
题目大意:给定一个n*m的矩形油田,油田中'*'代表空油井,'@'表示油井,每个油井@,与行,竖,对角线(也就是一般的8个方向)的油井都是联通的,
求一共有多少个油井联通块。
思路:题目说的很清楚,求的联通块的数量,直接dfs搞定,具体看代码,挺简单的,1A了
/*
    @author : liuwen
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}}; //8个方向
int G[105][105],vis[105][105],n,m;
void dfs(int x,int y)    //dfs求联通分量
{
    vis[x][y]=1;
    for(int i=0;i<8;i++){
        int nowX=x+dir[i][0];
        int nowY=y+dir[i][1];
        if(nowX>=0&&nowX<n&&nowY>=0&&nowY<m&&!vis[nowX][nowY]&&G[nowX][nowY]){
            dfs(nowX,nowY);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    char str[105];
    while(scanf("%d%d",&n,&m)==2){
        if(n==0||m==0)  break;
        memset(G,0,sizeof(G));
        for(int i=0;i<n;i++){
            scanf("%s",str);
            for(int j=0;j<m;j++){
                if(str[j]=='*') G[i][j]=0; //空油为0
                else G[i][j]=1; //油井为1
            }
        }
        int cnt=0;    //连同分量
        memset(vis,0,sizeof(vis)); //访问初始化
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(!vis[i][j]&&G[i][j]){
                    dfs(i,j);
                    cnt++;
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值