poj1979 Red and Black(dfs判断联通分量)

这篇博客详细解析了如何使用深度优先搜索(DFS)算法解决poj1979题目中关于判断联通分量的问题,通过实例输入和输出展示了算法的应用过程。
摘要由CSDN通过智能技术生成
Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 19925 Accepted: 10677

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
题目大意:给出一个网格图,#为不可到达区域,.为可到达区域,初始位置为@,求可以到达的最大格子数量 。
解体思路:这是一道很简单的题目,dfs判断联通分量即可。/*
/*
    @author : liuwen
*/
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <cmath>
using namespace std;
const int maxn=100;
const int dir[4][2]={{-1,0},{1,0},{0,-1},{0,1}}; //4个方向
int G[maxn][maxn],vis[maxn][maxn];
int iniX,iniY,n,m,cnt; //cnt为所走的网格数
void dfs(int x,int y)
{
    vis[x][y]=1;
    for(int i=0;i<4;i++){
        int nowX=x+dir[i][0];
        int nowY=y+dir[i][1];
        if(nowX>=0&&nowX<n&&nowY>=0&&nowY<m&&!vis[nowX][nowY]&&G[nowX][nowY]){
            cnt++;
            dfs(nowX,nowY);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    char str[50];
    while(scanf("%d%d",&m,&n)==2){
        if(n==0&&m==0)  break;
        memset(vis,0,sizeof(vis));
        memset(G,0,sizeof(G));
        for(int i=0;i<n;i++){
            scanf("%s",str);
            for(int j=0;j<m;j++){
                if(str[j]=='.') G[i][j]=1; //初始位置也可以达到
                else if(str[j]=='@') G[i][j]=1,iniX=i,iniY=j;
                else G[i][j]=0;
            }
        }
        cnt=1;         //初始位置为1
        dfs(iniX,iniY);
        printf("%d\n",cnt);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值