Dijkatra+Head_poj3268

Silver Cow Party
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10312 Accepted: 4574

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
解题思路:思想就是转置矩阵,先求x到所有点的最短路Dijkstra(x,n),转置后求Dijkstra(x,n)求的就是所有点到X的最短路,将两个最短路相加求最大值就是解。
转置   AddEdges(u,v,w)----->AddEdges(v,u,w);
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#include <string>
using namespace std;
#define forl(i,a,b)  for(int i=(a);i<(b);++i)
#define forle(i,a,b) for(int i=(a);i<=(b);++i)
#define forg(i,a,b)  for(int i=(a);i>(b);--i)
#define forge(i,a,b) for(int i=(a);i>=(b);--i)
#define mes(a,v)  memset(a, v, sizeof (a) );
#define cpy(a,b)  memcpy(a, b, sizeof (a) );
#define mesn(a, v, n) memset(a, v, (n)*sizeof((a)[0]))
#define cpyn(a, b, n) memcpy(a, v, (n)*sizeof((a)[0]))
const int maxn=2000;
const int maxe=2000000;
const int inf=200000000;
struct HeadNode
{
    int d,u;
    bool operator < (const HeadNode &r) const
    {
        return r.d<d;
    }
};
struct NodeEdges
{
    int to;
    int next;
    int w;
};
NodeEdges Edges[maxe];
int head[maxn],dist[maxn],dist1[maxn],u[maxe],v[maxe],w[maxe];
bool inque[maxn];
int n,x,m,Numedges;
void AddEdges(int u,int v,int w)
{
    Numedges++;
    Edges[Numedges].to=v;
    Edges[Numedges].w=w;
    Edges[Numedges].next=head[u];
    head[u]=Numedges;
}
void Dijktra(int s,int n)
{
    memset(dist,0,sizeof(dist));
    memset(inque,0,sizeof(inque));
    priority_queue<HeadNode>q;
    for(int i=1;i<=n;i++)   dist[i]=inf;
    dist[s]=0;
    q.push((HeadNode){dist[s],s});
    while(!q.empty())
    {
        HeadNode pi=q.top();
        q.pop();
        int u=pi.u;
        if(inque[u])    continue;
        inque[u]=true;
        for(int k=head[u];k!=-1;k=Edges[k].next)
        {
            if(dist[Edges[k].to]>Edges[k].w+pi.d)
            {
                dist[Edges[k].to]=Edges[k].w+pi.d;
                q.push((HeadNode){dist[Edges[k].to],Edges[k].to});
            }
        }
    }
}
int main()
{
    freopen("in.txt","r",stdin);
    while(scanf("%d%d%d",&n,&m,&x)==3)
    {
        Numedges=0;
        memset(Edges,0,sizeof(Edges));
        memset(head,-1,sizeof(head));
        memset(dist1,0,sizeof(dist1));
        memset(u,0,sizeof(u));
        memset(v,0,sizeof(v));
        memset(w,0,sizeof(w));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u[i],&v[i],&w[i]);
            AddEdges(u[i],v[i],w[i]);
        }
        Dijktra(x,n);
        for(int i=1;i<=n;i++)   dist1[i]=dist[i];

        Numedges=0;
        memset(head,-1,sizeof(head));
        memset(Edges,0,sizeof(Edges));
        for(int i=1;i<=m;i++)
            AddEdges(v[i],u[i],w[i]);
        Dijktra(x,n);

        int Max_ans=-inf;
        for(int i=1;i<=n;i++)
            Max_ans=max(dist[i]+dist1[i],Max_ans);

        printf("%d\n",Max_ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值