poj 1129 DFS+四色问题 Channel Allocation

Channel Allocation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10773 Accepted: 5523

Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels.

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input.

Following the number of repeaters is a list of adjacency relationships. Each line has the form:

A:BCDH

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form

A:

The repeaters are listed in alphabetical order.

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross.

Output

For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input

2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output

1 channel needed.
3 channels needed.
4 channels needed. 

解题思路:这是一个四色问题,运用四色定理可知道:
1:所有的转发器互不相邻,只要一种颜色;
2:用2或3种颜色去着色,看看是否成果。如果都不能实现着色,那就是4种颜色
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
bool cMap[30][30];  //存放无向图
int used[50];    //标记已经使用的颜色
int n;
bool Dfs(int id,int color)  //id是起始着色的节点,color是限制的着色数量
{
    int i,j;
    bool flag;         //着色成功的标志
    for(i=0;i<color;i++)       //在规定的颜色数中着色
    {
        flag=true;
        used[id]=i;      //节点id使用第i号颜色
        for(j=0;j<id;j++)   //判断相邻节点是否使用了该颜色
        {
            if(cMap[id][j]&&used[id]==used[j])
            {
                flag=false;            //该颜色已经使用,换一种颜色
                break;
            }
        }
        if(flag&&(id==n-1||Dfs(id+1,color)))  //该颜色有效,当所有节点着色完毕返回true,或者给下一个节点着色
            return true;
    }
    return false;
}
int main()
{
    //freopen("in.txt","r",stdin);
	int i,j;
	char adjacent[50];
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
		memset(cMap,0,sizeof(cMap));
		memset(used,0,sizeof(used));
		bool one=true;
		for(i=0;i<n;i++)
		{
			scanf("%s",adjacent);
            for(j=2;adjacent[j]!=0;j++,one=false)
			{
				cMap[i][adjacent[j]-'A']=true;
				cMap[adjacent[j]-'A'][i]=true;
			}
		}
		if(one)
            printf("1 channel needed.\n");
        else if(Dfs(1,2))
            printf("2 channels needed.\n");
        else if(Dfs(1,3))
            printf("3 channels needed.\n");
        else
            printf("4 channels needed.\n");
	}
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
POJ 1321 排兵布阵问题可以使用 DFS 算法求解。 题目要求在一个 n x n 的棋盘上,放置 k 个棋子,其中每行、每列都最多只能有一个棋子。我们可以使用 DFS 枚举每个棋子的位置,对于每个棋子,尝试将其放置在每一行中未被占用的位置上,直到放置了 k 个棋子。在 DFS 的过程中,需要记录每行和每列是否已经有棋子,以便在尝试放置下一个棋子时进行判断。 以下是基本的 DFS 模板代码: ```python def dfs(row, cnt): global ans if cnt == k: ans += 1 return for i in range(row, n): for j in range(n): if row_used[i] or col_used[j] or board[i][j] == '.': continue row_used[i] = col_used[j] = True dfs(i + 1, cnt + 1) row_used[i] = col_used[j] = False n, k = map(int, input().split()) board = [input() for _ in range(n)] row_used = [False] * n col_used = [False] * n ans = 0 dfs(0, 0) print(ans) ``` 其中,row 代表当前尝试放置棋子的行数,cnt 代表已经放置的棋子数量。row_used 和 col_used 分别表示每行和每列是否已经有棋子,board 则表示棋盘的状态。在尝试放置棋子时,需要排除掉无法放置的位置,即已经有棋子的行和列,以及棋盘上标记为 '.' 的位置。当放置了 k 个棋子时,即可计数一次方案数。注意,在回溯时需要将之前标记为已使用的行和列重新标记为未使用。 需要注意的是,在 Python 中,递归深度的默认限制为 1000,可能无法通过本题。可以通过以下代码来解除限制: ```python import sys sys.setrecursionlimit(100000) ``` 完整代码如下:
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值