题目链接:点击打开链接
Description
Our Black Box represents a primitive(原始的) database. It can save an integer(整数) array(数组) and has a special i variable(变量). At the initial moment Black Box is empty and i equals 0. This Black Box processes asequence(序列) of commands (transactions(交易)). There are two types of transactions:
ADD (x): put element(元素) x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located(处于) at i-th place after Black Box elements sorting by non-descending(下降).
Let us examine a possible sequence of 11 transactions:
Example 1
It is required to work out an efficient(有效率的) algorithm(算法) which treats a given sequence(序列) of transactions(交易). The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer(整数) arrays(数组):
1. A(1), A(2), ..., A(M): a sequence of elements(基础) which are being included into Black Box. A values are integers not exceeding(超过) 2 000 000 000 by their absolute(绝对的) value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality(不平等) p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.
ADD (x): put element(元素) x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located(处于) at i-th place after Black Box elements sorting by non-descending(下降).
Let us examine a possible sequence of 11 transactions:
Example 1
N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8
It is required to work out an efficient(有效率的) algorithm(算法) which treats a given sequence(序列) of transactions(交易). The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer(整数) arrays(数组):
1. A(1), A(2), ..., A(M): a sequence of elements(基础) which are being included into Black Box. A values are integers not exceeding(超过) 2 000 000 000 by their absolute(绝对的) value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality(不平等) p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.
Input
Input(投入) contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output(输出) Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
Sample Output
3
3
1
2
题意:第一行是序列 第二行的值i代表在输入第一行的第i个值时输出第
k大的数.k是从一开始的.(主要是看懂题意),用优先队列;
1>用升序的优先队列存储,在将最小的放入降序的优先队列中,这样就能找到第k小的值了(降序队列中只方k个值)
<span style="font-size:24px;">#include <iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<cstdlib>
#include<algorithm>
using namespace std;
int a[30005];
int b[30005];
int main()
{
int m,n;
priority_queue< int ,vector<int >, less<int > >q;
priority_queue< int ,vector<int >, greater<int > >p;
cin>>m>>n;
for(int i=1;i<=m;i++)
{
cin>>a[i];
}
for(int j=1;j<=n;j++)
{
cin>>b[j];
}
int i=0;
int j,k;
j=k=1;
while(j<=n)
{
if(i==b[j])
{
j++;
if(q.size()<k)
{
int t=p.top();
q.push(t);
p.pop();
}
int ans=q.top();
cout<<ans<<endl;
k++;
}
else
{
i++;
if(q.size()<k)
{
p.push(a[i]);
int t=p.top();
p.pop();
q.push(t);
}
else if(q.top()>a[i])
{
int t=q.top();
q.pop();
p.push(t);
q.push(a[i]);
}
else
{
p.push(a[i]);
}
}
}
return 0;
}</span>