lightoj-1370 Bi-shoe and Phi-shoe( 欧拉筛 求 欧拉函数)

传送门:http://lightoj.com/volume_showproblem.php?problem=1370

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题目大意:

有一个教练要给他的学生买竹子然后做成鞋子。买的竹子的长度都是欧拉函数值,然后每个学生都有一个幸运值,对于第i个学生的幸运值为ai,给这个学生买的竹子的长度必须大于等于ai才行,然后每节竹子需要1 xukha,问需要最少的钱是多少。

题解:

很容易想到的是要求每个数的欧拉函数值,然后在找那个最小的符合的数。求欧拉函数的办法可以用欧拉筛。

但是这个题一开始我不会欧拉筛,然后就打表发现,对于幸运值ai,找一个大于等于ai的欧拉函数值的是多少呢?发现是一个素数的欧拉值。因为素数p的欧拉值是p-1,然后又发现任意两个素数之间的欧拉函数值都比这两个素数的欧拉函数值小。这可以断定找一个最小的>=a[i]的数一定素数。然后把素数都找出来进行二分去找那个欧拉值>=a[i]素数。


///欧拉筛
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
typedef long long LL;
int phi[1000000];
void init()
{
    memset(phi,0,sizeof(phi));
    for(int i=2;i<=1000005;i++)
    {
        if(!phi[i])
        {
            for(int j=i;j<=1000005;j+=i)
            {
                if(!phi[j])phi[j]=j;
                phi[j]=phi[j]/i*(i-1);
            }
        }
    }
}
int main()
{
    init();
    int T,n,w=0,a;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a);
            int k=a;
            while(phi[k]<a)k++;
            ans+=k;
        }
        printf("Case %d: %lld Xukha\n",++w,ans);
    }
    return 0;
}
///方法2
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
typedef long long LL;
int vis[1000020],q[1000020];
int a[100020],top;
void init()
{
    memset(vis,0,sizeof(vis));
    int m=sqrt(0.5+1000010);
    for(int i=2;i<=m;i++)
    {
        if(!vis[i])
        {
            for(int j=i*i;j<=1000010;j+=i)
            {
                vis[j]=1;
            }
        }
    }
    top=0;
    for(int i=2;i<=1000003;i++)
    {
        if(!vis[i])q[++top]=i-1;
    }
}
int main()
{
    init();
    int T,n,w=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        LL ans=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            int l=1,r=top;
            while(l<r)
            {
                int mid=(l+r)>>1;
                if(a[i]<=q[mid])
                {
                   r=mid;
                }
                else
                {
                    l=mid+1;
                }
            }
            ans+=q[l]+1;
        }
        printf("Case %d: %lld Xukha\n",++w,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值