Bi-shoe and Phi-shoe (欧拉函数)

题目传送门:Bi-shoe and Phi-shoe | LightOJ

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

样例输入:

3
5
1 2 3 4 5
6
10 11 12 13 14 15
2
1 1
样例输出:

Case 1: 22 Xukha
Case 2: 88 Xukha
Case 3: 4 Xukha
题目大意:

        给你一串数字a[N],找到欧拉值大于等于a[i]的最小数的和。

解题思路:

        题目很长,实际就以上一句话,有了这句话,我们就可以做题了。首先用欧拉筛,计算出1e6内的每个数的欧拉值,接着就是遍历每一个数,找到欧拉值大于等于他的最小数,这里我们需要明白一个事情,那就是一个数的欧拉值一定比他小,所以我们只需要从a[i]开始从小到大遍历查找,看代码。

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int N=1e6+10;
#define INF 0x3f3f3f3f3f3f3f3f
typedef long long ll;
int n;
ll p[N],idx,phi[N];
bool st[N];
void get_eulers()
{
    for (ll i=2; i<N; i++) {
        if(!st[i])
        {
            p[idx++]=i;
            phi[i]=i-1;
        }
        for (int j=0; i*p[j]<N; j++) {
            st[i*p[j]]=true;
            if(i%p[j]==0)
            {
                phi[i*p[j]]=p[j]*phi[i];
                break;
            }
            phi[i*p[j]]=(p[j]-1)*phi[i];
        }
    }
}
int main()
{
    int t,tt=0;
    scanf("%d",&t);
    get_eulers();
    while(t--)
    {
        tt++;
        scanf("%d",&n);
        ll res=0;
        while(n--)
        {
            int x;
            scanf("%d",&x);
            for (int i=x; i<N; i++) {
                if(phi[i]>=x)
                {
                    res+=i;
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",tt,res);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值