ZOJ 3775 ?(>_o)!

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=5238

题目:

?(>_o)!

Time Limit: 2 Seconds       Memory Limit: 65536 KB

?(>_o)! is a pseudo-object-oriented programming language. It implements the following commands:

CommandDescription
?Check whether the character '?' is in the program's source code. If '?' does not exist in the program's source, the hardware will catch fire or explode.
(It tries to match ')', although mismatch of brackets does not matter at all.
>Increase the internal accumulator.
_Print the program's source code.
oInstantiate an object of a new sub class of the generic super class. Due to the best principles of object hiding, this object cannot be accessed in any way.
)Just matches '('. It's for patient with obsessive-compulsive disorder. However, mismatch of brackets does not matter at all.
!Print "Hello, world!".
Other charactersBe treated as comments rather than instruction.

However, it's only another joke programming language. There is even no way to access the accumulator. But it's one of easiest to finish a "Hello world" program or a quine program. A quine is a computer program which takes no input and produces a copy of its own source code as its only output. Your task is to judge whether a ?(>_o)! program is a quine.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

There is one line of string represents the source code of a ?(>_o)! program. The program contains no more than 256 characters. The ASCII value of each character is within [32, 126].

Output

For each test case, output "Yes" if it is a quine. Otherwise, output "No".

Sample Input
4
Hello, world!
source_code
source__code
?(>_o)!
Sample Output
Yes
Yes
No
No
Hint

The output of the four sample programs are {"Hello, world!", "source_code", "source__codesource__code", "?(>_o)!Hello, world!"} respectively. Therefore the first two programs are quines, and the last two are not.

Luckily, there is a '?' in the fourth program, so the hardware will not catch fire or explode during running the fourth program.


解题思路:

简单模拟


代码:

stl版本:

#include <iostream>
#include <string>
using namespace std;

string s, ss;

int main()
{
	int t;
	
	while(cin >> t)
	{
		cin.ignore();//相当于getchar()
		while(t--)
		{
			s = ss = "";
			getline(cin, s);//读取一行,此处不能用cin,因为cin读到空格就停
			int len = s.length();
			for(int i = 0; i < len; i++)
			{
				if('_' == s[i])
				{
					ss += s;
				}
				else if('!' == s[i])
				{
					ss += "Hello, world!";
				}
			}
			cout << (s == ss ? "Yes" : "No") << endl;
		}
	}
	
	return 0;
}

非stl版本:

#include <iostream>
#include <cstring>
#include <string>
#include <cstdio>
using namespace std;

const int MAXN = 100000;
char s[MAXN], ss[MAXN];

int main()
{
	int t;
	char st[] = "Hello, world!";
	
	while(~scanf("%d", &t))
	{
		getchar();
		while(t--)
		{
			for(int i = 0; i < MAXN; i++)
			{
				ss[i] = ' ';
			}
			gets(s);
			int len = strlen(s);
			int ls = 0;
			for(int i = 0; i < len; i++)
			{
				if('_' == s[i])
				{
					for(int j = 0; j < len; j++)
					{
						ss[ls++] = s[j];
					}
				}
				else if('!' == s[i])
				{
					for(int j = 0; j < strlen(st); j++)
					{
						ss[ls++] = st[j];
					}
				}
			}
			ss[ls] = '\0';
			printf("%s\n", 0 == strcmp(s, ss) ? "Yes" : "No");
		}
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值