ACdream区域赛指导赛之手速赛系列(4) E Tic-Tac-Toe-Tomek

题目:

Tic-Tac-Toe-Tomek

Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)
Problem Description

Tic-Tac-Toe-Tomek is a game played on a 4 x 4 square board. The board starts empty, except that a single 'T' symbol may appear in one of the 16 squares. There are two players: X and O. They take turns to make moves, with X starting. In each move a player puts her symbol in one of the empty squares. Player X's symbol is 'X', and player O's symbol is 'O'.

After a player's move, if there is a row, column or a diagonal containing 4 of that player's symbols, or containing 3 of her symbols and the 'T' symbol, she wins and the game ends. Otherwise the game continues with the other player's move. If all of the fields are filled with symbols and nobody won, the game ends in a draw. See the sample input for examples of various winning positions.

Given a 4 x 4 board description containing 'X', 'O', 'T' and '.' characters (where '.' represents an empty square), describing the current state of a game, determine the status of the Tic-Tac-Toe-Tomek game going on. The statuses to choose from are:

  • "X won" (the game is over, and X won)
  • "O won" (the game is over, and O won)
  • "Draw" (the game is over, and it ended in a draw)
  • "Game has not completed" (the game is not over yet)

If there are empty cells, and the game is not over, you should output "Game has not completed", even if the outcome of the game is inevitable.

Input

The first line of the input gives the number of test cases, T(1 ≤ T ≤ 1000).

T test cases follow. Each test case consists of 4 lines with 4 characters each, with each character being 'X', 'O', '.' or 'T' (quotes for clarity only).

Each test case is followed by an empty line.

Output

For each test case, output one line containing "Case #x: y", where x is the case number (starting from 1) and y is one of the statuses given above.

Make sure to get the statuses exactly right.

When you run your code on the sample input, it should create the sample output exactly, including the "Case #1: ", the capital letter "O" rather than the number "0", and so on.

Sample Input
6
XXXT
....
OO..
....

XOXT
XXOO
OXOX
XXOO

XOX.
OX..
....
....

OOXX
OXXX
OX.T
O..O

XXXO
..O.
.O..
T...

OXXX
XO..
..O.
...O
Sample Output
Case #1: X won
Case #2: Draw
Case #3: Game has not completed
Case #4: O won
Case #5: O won
Case #6: O won

传送门: 点击打开链接

解题思路:

模拟

代码:

#include <cstdio>
#include <iostream>
#include <string>
#include <cstring>
#include <algorithm>
using namespace std;
 
int t, w = 1;
char map[10][10];
 
bool same(char c)
{
    for(int i = 0; i < 4; ++i)
    {
        int a = 0, b = 0;
        for(int j = 0; j < 4; ++j)
        {
            if(c == map[i][j])
            {
                a++;
            }
            if('T' == map[i][j])
            {
                b++;
            }
        }
        if((4==a&&0==b) || (3==a&&1==b)) return true;
    }
    for(int j = 0; j < 4; ++j)
    {
        int a = 0, b = 0;
        for(int i = 0; i < 4; ++i)
        {
            if(c == map[i][j])
            {
                a++;
            }
            if('T' == map[i][j])
            {
                b++;
            }
        }
        if((4==a&&0==b) || (3==a&&1==b)) return true;
    }
    int a = 0, b = 0;
    for(int i = 0; i < 4; ++i)
    {
        if(c == map[i][i])
        {
            a++;
        }
        if('T' == map[i][i])
        {
            b++;
        }
    }
    if((4==a&&0==b) || (3==a&&1==b)) return true;
    a = 0, b = 0;
    for(int i = 0; i < 4; ++i)
    {
        if(c == map[i][3-i])
        {
            a++;
        }
        if('T' == map[i][3-i])
        {
            b++;
        }
    }
    if((4==a&&0==b) || (3==a&&1==b)) return true;
    return false;
}
 
int main()
{
    scanf("%d", &t);
    getchar();
    while(t--)
    {
        int num = 0;
        for(int i = 0; i < 4; ++i)
        {
            for(int j = 0; j < 4; ++j)
            {
                 map[i][j] = getchar();
                 if('.' == map[i][j]) num++;
            }
            getchar();
        }
        getchar();
        printf("Case #%d: ", w++);
        if(same('X')) printf("X won\n");
        else if(same('O')) printf("O won\n");
        else if(0 == num) printf("Draw\n");
        else printf("Game has not completed\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值