UVA 11300 - Spreading the Wealth

题目:

 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. nlines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4


传送门:点击打开链接

解题思路:

先求出序列a的平均值ave,数组c, c[0] = 0, c[1] = a[0] - ave, c[2] = a[0]+a[1] - 2*ave, c[3] = a[0]+a[1]+a[2]-3*ave...求出数组c的中位数m,∑abs(c[i]-m)即为我们所求的答案。ps:long long 在UVA上要使用lld

代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

typedef long long lint;
const int MAXN = 1e6+10;
int n;
lint a[MAXN], c[MAXN];

int main()
{
    while(~scanf("%d", &n))
    {
        lint ave = 0;
        for(int i = 0; i < n; ++i)
        {
            scanf("%lld", &a[i]);
            ave += a[i];
        }
        ave /= n;
        c[0] = 0;
        for(int i = 1; i < n; ++i)
            c[i] = c[i-1] + a[i] - ave;
        sort(c, c+n);
        lint ans = 0;
        for(int i = 0; i < n; ++i)
            ans += abs(c[i]-c[n/2]);
        printf("%lld\n", ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值