Proble B ZOJ 3203 Light Bulb

Light Bulb

Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb while h is the height of mildleopard.D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, andH - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
 
ps:感谢莫莫的解题报告  
 

 这个题目因为先前做过,印象也比较深刻,主要把公式推出来,然后三分,求最长的影子即可。

题意: 按图所示,人左右走动,求影子L的最长长度。

解题思路:

根据图,很容易发现当灯,人的头部和墙角成一条直线时,此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人头、墙角、灯成一条线的地点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用三分来求解。

      如图,影子的长度即为BC+CE  即为 l+d*(h-l)/(H-l)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
using namespace std;

double H,h,d,sum;
double calc(double l)
{
  return l+d*(h-l)/(H-l);
}

int main()
{
   int num;
   scanf("%d",&num);
   while(num--)
   {
     scanf("%lf%lf%lf",&H,&h,&d);
       double left=0,right=h;
       while(left+0.00001<right)             //三分解题思想
      {
        double mid=(left+right)/2;
      double mimid=(mid+right)/2;
        if(calc(mid)>calc(mimid))
            right=mimid;
         else
              left=mid;
       }
       printf("%.3lf\n",calc(left));
   }
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值