FatMouse' Trade

FatMouse' Trade

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13 Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500
程序:
#include <iostream> 
#include <iomanip>  
using namespace std;  
struct Trade 
{  
    int javaBean, food;  
    double rate;  
};  
  
int main()  
{  
        const int max = 1001;  
        int catFood, N;  
        int i, j, f, maxIdx;  
        double r, get;  
        Trade record[max], tmp;  
        while (cin >> catFood >> N && (catFood != -1) && (N != -1)) 
		{  
                i = get = 0;  
                while (i < N) 
				{  
                        cin >> j >> f;  
                        if (j == 0)  
                                r = 0.0;  
                        else if (f == 0)  
                                r = static_cast<double>(max);  
                        else  
                                r = 1.0 * j/f;  
                        record[i].javaBean = j;  
                        record[i].food = f;  
                        record[i].rate = r;  
                        i++;  
                }    
                for (j = 0; j < N - 1; j++) 
				{    
                        maxIdx = N - 1;  
                        for (f = j; f < N; f++)
						{  
                                if (record[maxIdx].rate < record[f].rate)  
                                maxIdx = f;  
                        }   
                        tmp = record[j];  
                        record[j] = record[maxIdx];  
                        record[maxIdx] = tmp;  
				} 
                for (i = 0; i < N; i++) 
				{  
                        f = record[i].food;  
                        j = record[i].javaBean;  
                        if (catFood >= f)
						{  
                                get += j;  
                                catFood -= f;  
                        }
						else
						{  
                                r = 1.0 * catFood / f;  
                                get += j * r;  
                                catFood = 0;  
                        }  
                }


				cout<<setiosflags(ios::fixed)<<setprecision(3)<<get<<endl;
               
        }  
  
        return 0;  
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值