Tian Ji -- The Horse Racing

Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0
 

Sample Output
200
0
0
 


Source
2004 Asia Regional Shanghai
 

Recommend
JGShining
 


#include<stdio.h>
#include<stdlib.h>

/*
Solution:这题有多种解体思路,DP,二分图最大匹配算法等,这里给出的是比较容易理解的贪心算法,具体思路如下:

先将田忌跟齐王的马的速度数组进行一次冒泡排序

1、如果田忌最快的马比齐王最快的马快,则比之  

2、如果田忌最快的马比齐王最快的马慢,则用田最慢的马跟齐最快的马比  //这是贪心的第一步

3、如果田忌最快的马的速度与齐威王最快的马速度相等

3.1、如果田忌最慢的比齐威王最慢的快,则比之                         //这是贪心的第二步

3.2、如果田忌最慢的比齐威王最慢的慢,田忌慢VS齐王快

3.3、田忌最慢的与齐威王最慢的相等,田忌慢VS齐王快
*/

int comp(const void *a,const void *b)
{
    return *(int *)b - *(int *)a;//为由大到小排序
}

int main(void)
{
    int TianJi[1000];
    int King[1000];
    int i=0,j=0;
    int Num=0;
    int Money=0;
    int  TianCount=0,KingCount=0,Count=0;
    while(scanf("%d",&Num))
    {
        if(Num==0)
            break;
        else
        {
            for(i=0;i<Num;i++)
            {
                scanf("%d",&TianJi[i]);
            }
            for(i=0;i<Num;i++)
            {
                scanf("%d",&King[i]);
            }

            qsort(TianJi, Num, sizeof(int), comp);
            qsort(King, Num, sizeof(int), comp);

            i=0;
            j=0;
            Money=0;
            KingCount=Num-1;
            TianCount=Num-1;
            Count=0;

            while(1)
            {
                if(Count==Num)   break;  //表征全部马比完
                if(TianJi[i]>King[j])//田忌最快的比国王快
                {
                    Money=Money+200;
                    i=i+1;
                    j=j+1;
                    Count++;
                    continue;//提前结束本次循环
                }

                if(TianJi[i]<King[j])//田忌最快的比国王慢
                {
                    Money=Money-200;
                    TianCount=TianCount-1;
                    j=j+1;
                    Count++;
                    continue;//提前结束本次循环 进入下一次循环
                }

                if(TianJi[i]==King[j])//田忌最快的和国王一样
                {
                    if(TianJi[TianCount]>King[KingCount])//田忌最慢的比国王快
                    {
                         Money=Money+200;
                         TianCount--;
                         KingCount--;
                         Count++;
                         continue;
                    }

                    //田忌最慢的不比国王最慢的快 则和国王的快马相比
                    if(TianJi[TianCount]<King[j])//和国王的快马相比 田忌慢马较慢
                    {
                        Money=Money-200;
                        j++;
                        TianCount--;
                        Count++;
                    }

                    else {TianCount--;j++;Count++;}//现在剩余就是国王最快的和田忌最慢的都相等的情况,
                    continue;
                }
            }
            printf("%d\n",Money);
        }
    }

    return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值