hdu1142A Walk Through the Forest (最短路+BFS+DFS )

Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0

Sample Output
  
  
2 4
题目意思是:如果从A到B有路,并且A到终点的最小距离大于B到终点的最小距离,问有多少种走法。
思路:先从终点出发,把每一点到终点的距离算出来,然后主要在DFS上,算出每一点有多少种走法,有DP思想。
#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;

typedef struct n1
{
    int  distens,flog;
    //friend bool operator<(n1 n,n1 nn)
    //{
    //    return nn.distens<n.distens;
    //}
}node;
node N[1005];
int map[1005][1005],k;
int direct[1005];
void set(int n)
{
    int i,j,m,n1,n2,d;
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            map[i][j]=-1;
        }
         N[i].distens=10000000;N[i].flog=0;direct[i]=0;
    }

    scanf("%d",&m);
    while(m--)
    {
        scanf("%d%d%d",&n1,&n2,&d);
        if(map[n1][n2]!=0||map[n1][n2]>d)
        map[n1][n2]=map[n2][n1]=d;
    }
}
void BFS(int n)
{
    queue<int> Q;
    int now;
    int i;
     N[2].distens=0;N[2].flog=1;
    Q.push(2);
    while(!Q.empty())//算出每个点到终到的最小距离
    {
        now=Q.front();
        Q.pop();
        N[now].flog=0;
        //if(q.x==1)break;
        for(i=1;i<=n;i++)
        if(map[now][i]!=-1)
        {
            if(N[i].distens>N[now].distens+map[now][i])
            {
                N[i].distens=N[now].distens+map[now][i];
                if(N[i].flog==0)
                {
                    N[i].flog=1;
                    Q.push(i);
                }
            }
        }
    }
}
int DFS(int now,int n)
{
    int i;
    if(direct[now]>0)//direct表示当前点到终点有多少种走法,为了下次搜到这个点就不必往下搜了,直接反回
    return direct[now];
    if(now==2)
    {
        return 1;
    }
    for(i=1;i<=n;i++)
    if(map[now][i]!=-1&&N[now].distens>N[i].distens)
    {
        direct[now]+=DFS(i,n);
    }

   return direct[now];
}
int main()
{
    int n;
    while(scanf("%d",&n)>0&&n)
    {
        set(n);
        BFS(n);
        k=DFS(1,n);
        printf("%d\n",k);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值