poj 2104 K-th Number (主席树)

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it — the k-th number in sorted a[i…j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

题意

给定一组数据,每次询问一个区间内第K大的值。

题解

主席树好难啊~~我个蒟蒻还是不能很清明。最近看了很多主席树的板子,每一个都不一样,已疯。最后还是抱紧某大佬的板子(雏鸟情结型板子)啃题。有些地方还是模模糊糊不清楚,但是能打出个大概的框架了。大佬对我爱答不理(嫌弃),嘤嘤QAQ。
主席树一般适用与有前缀和性质的线段树(值域线段树之类的)。核心思想是开一个数组,每一个数下面挂一棵树(这里的数是抽象的下标,实际上这棵树里多存的就是这个下标所表示的东西)。因为是与之前的树累加起来,新建一棵树太麻烦,就直接复制粘贴前一棵树(实际上只是指向前一棵树)然后在本体上再添加就行了。之后再利用前缀和的性质硬刚。

代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N = 2000010;

struct Node {
    int l, r, ls, rs, sum;
} t[N];
int n, m, tot, tail = 0, a[N], temp[N], root[N];

void update(int num) {
    t[num].sum = t[t[num].ls].sum + t[t[num].rs].sum;
}

int build(int l, int r) {
    int num = ++ tail;
    t[num].l = l, t[num].r = r;
    if(l == r)
        return num;
    int mid = (l + r) >> 1;
    t[num].ls = build(l, mid);
    t[num].rs = build(mid + 1, r);
    return num;
}

int modify(int pre, int pos) {
    int num = ++ tail;
    t[num] = t[pre];
    if(t[num].l == t[num].r) {
        t[num].sum ++;
        return num;
    }
    int mid = (t[num].l + t[num].r) >> 1;
    if(pos <= mid)
        t[num].ls = modify(t[pre].ls, pos);
    else
        t[num].rs = modify(t[pre].rs, pos);
    update(num);
    return num;
}

int query(int k, int r1, int r2) {
    if(t[r1].l == t[r1].r)
        return t[r1].l;
    int lnum = t[t[r2].ls].sum - t[t[r1].ls].sum;
    int mid = (t[r1].l + t[r1].r) >> 1;
    if(k <= lnum)
        return query(k, t[r1].ls, t[r2].ls);
    else 
        return query(k - lnum, t[r1].rs, t[r2].rs);
}

int main() {
    scanf("%d %d", &n, &m);
    for(int i = 1; i <= n; i ++) {
        scanf("%d", &a[i]);
        temp[i] = a[i];
    }
    sort(temp + 1, temp + n + 1);
    tot = unique(temp + 1, temp + n + 1) - temp - 1;
    root[0] = build(0, n);
    for(int i = 1; i <= n; i ++) {
        int now = lower_bound(temp + 1, temp + tot + 1, a[i]) - temp;
        root[i] = modify(root[i - 1], now);
    }
    while(m --) {
        int l, r, k;
        scanf("%d %d %d", &l, &r, &k);
        int p = query(k, root[l - 1], root[r]);
        printf("%d\n", temp[p]);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值