hdu 1297 Children’s Queue

19 篇文章 0 订阅
4 篇文章 0 订阅

Children’s Queue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 20   Accepted Submission(s) : 6
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

Sample Input

1
2
3

Sample Output

1
2
4

Author

SmallBeer (CML)

Source

杭电ACM集训队训练赛(VIII)
 
注意:
1、递归公式
1)m

2)mff

3)mfff

a:安全序列后加ff或者m,结果仍然安全。

b:不安全序列后加ff可使其安全,虽然mf加f也能得到安全序列,但与a情况重复。

故:公式a[n]=a[n-1]+a[n-2]+a[n-4];

2、大数,高精度问题。可以用二维数组模拟大数计算。
 
 
#include<stdio.h> 
int main()
{ 
 int n; 
 int f[1001][101] = {0};
 f[0][1] = 1;
 f[1][1] = 1;
 f[2][1] = 2;
 f[3][1] = 4; 
 for(int i = 4; i < 1001; ++i)
 { 
  for(int j = 1; j < 101; ++j)
  { 
   f[i][j] += f[i - 1][j] + f[i - 2][j] + f[i - 4][j]; //数组的每一位相加 
   
   f[i][j + 1] += f[i][j] / 10000; //超过4位的部分保存至数组下一位中
   
   f[i][j] %= 10000; //每位数组只保存其中4位 
   
  } 
 } 
 while(scanf("%d", &n) != EOF)
 { 
  int k = 100; 
  while(!f[n][k--]);            //排除前面为空的数组 
  printf("%d", f[n][k + 1]);    //输出结果的前四位
  
  for(; k > 0; --k)
  { 
   printf("%04d", f[n][k]);//输出其余的所有四位数字,若数字小于四位,则前面用0填充 
  } 
  printf("\n");
 } 
 return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值