zoj3529 A Game Between Alice and Bob

16 篇文章 0 订阅
A Game Between Alice and Bob

Time Limit: 5 Seconds Memory Limit: 262144 KB

Alice and Bob play the following game. A series of numbers is written on the blackboard. Alice and Bob take turns choosing one of the numbers, and replace it with one of its positive factor but not itself. The one who makes the product of all numbers become 1 wins. You can assume Alice and Bob are intelligent enough and Alice take the first turn. The problem comes, who is the winner and which number is Alice's first choice if she wins?

Input

This problem contains multiple test cases. The first line of each case contains only one number N (1<= N <= 100000) representing there are N numbers on the blackboard. The second line contains N integer numbers specifying the N numbers written on the blackboard. All the numbers are positive and less than or equal to 5000000.

Output

Print exactly one line for each test case. The line begins with "Test #c: ", where c indicates the case number. Then print the name of the winner. If Alice wins, a number indicating her first choice is acquired, print its index after her name, separated by a space. If more than one number can be her first choice, make the index minimal.

Sample Input
4
5 7 9 12
4
41503 15991 72 16057 
Sample Output
Test #1: Alice 1
Test #2: Bob
sg涵数打表可以看出,sg值就是这个数的质因数的个数,这样,我们就可以先打出素数表,优化时间!
#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;
#define M 10000001
int pri[100050],prime[20000],cnt;
bool flag[M]={0};
void init(){
    int i,n=sqrt(M),j;
    cnt=0;
    for(i=2;i<=n;i++){
        if(flag[i])
        continue;
        prime[cnt++]=i;
        for(j=i+i;j<=n;j=j+i){
            flag[j]=1;
        }
    }
}
int getsg(int x){
    int i,k=0;
    for(i=0;i<cnt&&prime[i]*prime[i]<=x;i++){
        while(x%prime[i]==0){
            x/=prime[i];
            k++;
        }
    }
    if(x!=1)k++;
    return k;
}
int main()
{
    int n,i,ans,tt=1;
    init();
    while(scanf("%d",&n)!=EOF){
        for(ans=0,i=0;i<n;i++){
            scanf("%d",&pri[i]);
            pri[i]=getsg(pri[i]);
            ans^=pri[i];
        }
        printf("Test #%d: ",tt++);
        if(ans){
            printf("Alice");
            for(i=0;i<n;i++)
            if(pri[i]>=(ans^pri[i])){
                printf(" %d\n",i+1);
                break;
            }
        }
        else {
            printf("Bob\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值