hdu 4861 Couple doubi


Couple doubi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 201    Accepted Submission(s): 171


Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input
Multiply Test Cases. 
In the first line there are two Integers k and p(1<k,p<2^31).
 

Output
For each line, output an integer, as described above.
 

Sample Input
  
  
2 3 20 3
 

Sample Output
  
  
YES NO

题目大意

给你k个球以及n(素数),下面每个球i的价值可以由公式 1^i+2^i+...+(p-1)^i (mod p)算出,一个人先取球(肯定是球中最大的了),然后另外一个人取(也肯定是剩下的球中最大的),最后取完后比较两个人所取的球的价值的总数谁大谁小,先手大输出YES否则输出NO。

多校的第一题,在强行找规律下面竟然还找出了规律。


其实是由费马小定理:g    (p1)%p=1

g=(1~p-1) 这样的话球的第(p-1)个,第(p-1)*2个......一直到第(p-1)*n个 价值是为(p-1)。

别的都是0;(没看太懂,明天证)


#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;
typedef long long ll;
ll k, p;

int main () {
    while (cin >> k >> p) {
        ll t = k / (p-1);    
        if (t&1)
            cout << "YES" << endl;
        else
            cout << "NO" << endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值