Time Limit: 5000MS | Memory Limit: 65536K | |
Total Submissions: 27660 | Accepted: 13008 | |
Case Time Limit: 2000MS |
Description
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.
Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.
Input
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Sample Input
6 3 1 7 3 4 2 5 1 5 4 6 2 2
Sample Output
6 3 0
Source
#include<stdio.h>
#include<string.h>
int n,m,a[200500],c1[200500],c2[200500];
int MAX(int a,int b)
{
if(a>b) return a;
return b;
}
int MIN(int a,int b)
{
if(a<b) return a;
return b;
}
void init1(int l,int r,int pos)
{
int mid=(l+r)/2;
if(l==r){ c1[pos]=a[l]; return; }
init1(l,mid,2*pos),init1(mid+1,r,2*pos+1);
c1[pos]=MAX(c1[2*pos],c1[2*pos+1]);
}
void init2(int l,int r,int pos)
{
int mid=(l+r)/2;
if(l==r){ c2[pos]=a[l]; return; }
init2(l,mid,2*pos),init2(mid+1,r,2*pos+1);
c2[pos]=MIN(c2[2*pos],c2[2*pos+1]);
}
int ques1(int l,int r,int pos,int templ,int tempr)
{
int mid=(l+r)/2;
if(templ<=l&&r<=tempr) return c1[pos];
else if(templ>mid) return ques1(mid+1,r,2*pos+1,templ,tempr);
else if(tempr<=mid) return ques1(l,mid,2*pos,templ,tempr);
return MAX(ques1(l,mid,2*pos,templ,mid),ques1(mid+1,r,2*pos+1,mid+1,tempr));
}
int ques2(int l,int r,int pos,int templ,int tempr)
{
int mid=(l+r)/2;
if(templ<=l&&r<=tempr) return c2[pos];
else if(templ>mid) return ques2(mid+1,r,2*pos+1,templ,tempr);
else if(tempr<=mid) return ques2(l,mid,2*pos,templ,tempr);
return MIN(ques2(l,mid,2*pos,templ,mid),ques2(mid+1,r,2*pos+1,mid+1,tempr));
}
int main()
{
int i,x,y;
while(scanf("%d%d",&n,&m)>0)
{
for(i=1;i<=n;i++) scanf("%d",a+i);
init1(1,n,1),init2(1,n,1);
for(i=0;i<m;i++)
{
scanf("%d%d",&x,&y);
printf("%d\n",ques1(1,n,1,x,y)-ques2(1,n,1,x,y));
}
}
return 0;
}