hdu 3006 The Number of set

Problem Description

Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.

Input

There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.

Output

For each case,the output contain only one integer,the number of the different sets you get.

Sample Input

4 4

1 1

1 2

1 3

1 4

2 4

3 1 2 3

4 1 2 3 4

Sample Output

15

2

思路:

用二进制的每一位来表示一个数,比如最低位为1表示1,倒数第二位为1表示2。

对各个集合进行或运算即可完成相加去重的过程。

#include <cstring>
#include <iostream>
#include <cstdlib>
using namespace std;

bool vis[1<<15];
int main()
{
    int n, m;
    while (scanf("%d%d", &n, &m) != EOF)
    {
        memset(vis, false, sizeof(vis));
        for(int i = 1; i <= n; i++)
        {
            int k, a, res = 0;
            scanf("%d", &k);
            while (k--)
            {
                scanf("%d", &a);
                res |= 1 << (a-1);
            }
            vis[res] = true;
            for(int j = 0; j < (1<<m); j++)
            {
                if (vis[j])
                {
                	vis[j|res] = true;
                }
            }
        }
        int result = 0;
        for (int i = 0; i < (1<<m); i++)
        {
        	if (vis[i])
        	{
        		result++;
        	}
        }
        printf("%d\n", result);
    }
    
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值