Power Strings
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 27102 | Accepted: 11347 |
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd aaaa ababab .
Sample Output
1 4 3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
题意:找出符合定义的字符串乘法的次方最高的n
题解:显然若字符串不是由几个循环组成,则n=1,若有循环,则循环长度为len-next【len+1】,显然根据next数组相等关系的迭代,若next【len+1】的长度小于字符串的一半,则不会有循环,反之,还要满足假设的循环可以被len整除,则有循环,输出循环出现的次数即可
#include<stdio.h>
#include<string.h>
char s[1000005];
int next[1000005];
void get_next()
{
int len=strlen(s+1),i=1,j;
next[1]=j=0;
while(i<=len)
{
if(j==0||s[i]==s[j]) next[++i]=++j;
else j=next[j];
}
}
void solve()
{
int len=strlen(s+1);
if((next[len+1]-1)*2>=len&&len%(len-(next[len+1]-1))==0)
printf("%d\n",len/(len-(next[len+1]-1)));
else printf("1\n");
}
int main()
{
while(scanf("%s",&s[1]),s[1]!='.')
{
get_next();
solve();
}
return 0;
}