Saving Princess claire_
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1874 Accepted Submission(s): 646
Problem Description
Princess claire_ was jailed in a maze by Grand Demon Monster(GDM) teoy.
Out of anger, little Prince ykwd decides to break into the maze to rescue his lovely Princess.
The maze can be described as a matrix of r rows and c columns, with grids, such as 'Y', 'C', '*', '#' and 'P', in it. Every grid is connected with its up, down, left and right grids.
There is only one 'Y' which means the initial position when Prince ykwd breaks into the maze.
There is only one 'C' which means the position where Princess claire_ is jailed.
There may be many '*'s in the maze, representing the corresponding grid can be passed through with a cost of certain amount of money, as GDM teoy has set a toll station.
The grid represented by '#' means that you can not pass it.
It is said that as GDM teoy likes to pee and shit everywhere, this grid is unfortunately damaged by his ugly behavior.
'P' means it is a transmission port and there may be some in the maze. These ports( if exist) are connected with each other and Prince ykwd can jump from one of them to another.
They say that there used to be some toll stations, but they exploded(surely they didn't exist any more) because of GDM teoy's savage act(pee and shit!), thus some wormholes turned into existence and you know the following things. Remember, Prince ykwd has his mysterious power that he can choose his way among the wormholes, even he can choose to ignore the wormholes.
Although Prince ykwd deeply loves Princess claire_, he is so mean that he doesn't want to spend too much of his money in the maze. Then he turns up to you, the Great Worker who loves moving bricks, for help and he hopes you can calculate the minimum money he needs to take his princess back.
Out of anger, little Prince ykwd decides to break into the maze to rescue his lovely Princess.
The maze can be described as a matrix of r rows and c columns, with grids, such as 'Y', 'C', '*', '#' and 'P', in it. Every grid is connected with its up, down, left and right grids.
There is only one 'Y' which means the initial position when Prince ykwd breaks into the maze.
There is only one 'C' which means the position where Princess claire_ is jailed.
There may be many '*'s in the maze, representing the corresponding grid can be passed through with a cost of certain amount of money, as GDM teoy has set a toll station.
The grid represented by '#' means that you can not pass it.
It is said that as GDM teoy likes to pee and shit everywhere, this grid is unfortunately damaged by his ugly behavior.
'P' means it is a transmission port and there may be some in the maze. These ports( if exist) are connected with each other and Prince ykwd can jump from one of them to another.
They say that there used to be some toll stations, but they exploded(surely they didn't exist any more) because of GDM teoy's savage act(pee and shit!), thus some wormholes turned into existence and you know the following things. Remember, Prince ykwd has his mysterious power that he can choose his way among the wormholes, even he can choose to ignore the wormholes.
Although Prince ykwd deeply loves Princess claire_, he is so mean that he doesn't want to spend too much of his money in the maze. Then he turns up to you, the Great Worker who loves moving bricks, for help and he hopes you can calculate the minimum money he needs to take his princess back.
Input
Multiple cases.(No more than fifty.)
The 1st line contains 3 integers, r, c and cost. 'r', 'c' and 'cost' is as described above.(0 < r * c <= 5000 and money is in the range of (0, 10000] )
Then an r * c character matrix with 'P' no more than 10% of the number of all grids and we promise there will be no toll stations where the prince and princess exist.
The 1st line contains 3 integers, r, c and cost. 'r', 'c' and 'cost' is as described above.(0 < r * c <= 5000 and money is in the range of (0, 10000] )
Then an r * c character matrix with 'P' no more than 10% of the number of all grids and we promise there will be no toll stations where the prince and princess exist.
Output
One line with an integer, representing the minimum cost. If Prince ykwd cannot rescue his princess whatever he does, then output "Damn teoy!".(See the sample for details.)
Sample Input
1 3 3 Y*C 1 3 2 Y#C 1 5 2 YP#PC
Sample Output
3 Damn teoy! 0
Author
BUPT
Source
Recommend
zhuyuanchen520
题意:又Y去到C,#不能走,*要花费cost,P可以传送到任意其他P,求最少花费
题解:一个简单的bfs就可以了
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<queue>
using namespace std;
struct point
{
int x,y;
long long mon;
point() {}
point(int _x,int _y,long long _m):x(_x),y(_y),mon(_m) {}
} p[5005],sta,fin,temp,now;
int r,c,cost,allp;
char mip[5005];
bool mark[5005];
int d[4][2]= {{0,-1},{0,1},{1,0},{-1,0}};
int judge(struct point temp)
{
if(0<=temp.x&&temp.x<r&&0<=temp.y&&temp.y<c) return 1;
return 0;
}
long long bfs()
{
int flag=1,i,k,x,y;
queue<point>q;
memset(mark,false,sizeof(mark));
q.push(point(sta.x,sta.y,0));
while(!q.empty())
{
now=q.front();
q.pop();
if(now.x==fin.x&&now.y==fin.y) return now.mon;
for(k=0; k<4; k++)
{
temp=point(now.x+d[k][0],now.y+d[k][1],now.mon);
if(judge(temp)&&mark[temp.x*c+temp.y]==false)
{
mark[temp.x*c+temp.y]=true;
if(flag&&mip[temp.x*c+temp.y]=='P')
{
flag=0;
for(i=0; i<allp; i++)
{
x=p[i].x; y=p[i].y;
if(mark[x*c+y]==false)
{
mark[x*c+y]=true;
q.push(point(x,y,temp.mon));
}
}
}
else if(mip[temp.x*c+temp.y]=='C') q.push(temp);
else if(mip[temp.x*c+temp.y]=='*') q.push(point(temp.x,temp.y,temp.mon+cost));
}
}
}
return -1;
}
int main()
{
int i,j;
long long res;
//freopen("t","r",stdin);
while(scanf("%d%d%d",&r,&c,&cost)>0)
{
for(allp=i=0; i<r; i++)
{
scanf("%s",mip+i*c);
for(j=0; j<c; j++)
{
if(mip[i*c+j]=='P') p[allp++]=point(i,j,0);
else if(mip[i*c+j]=='Y') sta=point(i,j,0);
else if(mip[i*c+j]=='C') fin=point(i,j,0);
}
}
res=bfs();
if(res==-1) printf("Damn teoy!\n");
else printf("%lld\n",res);
}
return 0;
}