UVa494 Kindergarten Counting Game


 Kindergarten Counting Game 

Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one).A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed ona separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...

Sample Output

2
7
10
9

这题大意就是要求一串字符串中有多少个单词,对于一串字符串,用一个标记表示是否添加单词个数,每当遇到一个字母如果标记为真,单词数目+1,且标记变为假,当遇到其他字符时,标记再变为真,遍历输出即可。

#include <iostream>
#include <cstdio>
#include <cctype>
using namespace std;

const int N = 10000;

int main() {
	char s[N];
	while (gets(s)) {
		int num = 0;
		bool cnt = true;
		for (int i = 0; i < N && s[i]; i++) {
			if (isalpha(s[i])) {
				if (cnt) {
					cnt = false;
					num++;
				}
			}
			else {
				cnt = true;
			}
		}
		cout << num << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值