Kindergarten Counting Game
Kindergarten Counting Game |
Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?
Input and Output
Input to your program will consist of a series of lines, each line containing multiple words (at least one).A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).
Your program should output a word count for each line of input. Each word count should be printed ona separate line.
Sample Input
Meep Meep! I tot I taw a putty tat. I did! I did! I did taw a putty tat. Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...
Sample Output
2 7 10 9
这题大意就是要求一串字符串中有多少个单词,对于一串字符串,用一个标记表示是否添加单词个数,每当遇到一个字母如果标记为真,单词数目+1,且标记变为假,当遇到其他字符时,标记再变为真,遍历输出即可。
#include <iostream>
#include <cstdio>
#include <cctype>
using namespace std;
const int N = 10000;
int main() {
char s[N];
while (gets(s)) {
int num = 0;
bool cnt = true;
for (int i = 0; i < N && s[i]; i++) {
if (isalpha(s[i])) {
if (cnt) {
cnt = false;
num++;
}
}
else {
cnt = true;
}
}
cout << num << endl;
}
return 0;
}