HDU 6114 Chess 【组合数】(2017"百度之星"程序设计大赛 - 初赛(B))

63 篇文章 0 订阅
28 篇文章 0 订阅

Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 513    Accepted Submission(s): 319



Problem Description
車是中国象棋中的一种棋子,它能攻击同一行或同一列中没有其他棋子阻隔的棋子。一天,小度在棋盘上摆起了许多車……他想知道,在一共N×M个点的矩形棋盘中摆最多个数的車使其互不攻击的方案数。他经过思考,得出了答案。但他仍不满足,想增加一个条件:对于任何一个車A,如果有其他一个車B在它的上方(車B行号小于車A),那么車A必须在車B的右边(車A列号大于車B)。

现在要问问你,满足要求的方案数是多少。
 

Input
第一行一个正整数T,表示数据组数。

对于每组数据:一行,两个正整数N和M(N<=1000,M<=1000)。
 

Output
对于每组数据输出一行,代表方案数模1000000007(1e9+7)。
 

Sample Input
  
  
1 1 1
 

Sample Output
  
  
1
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6143  6142  6141  6140  6139 
 

Statistic |  Submit |  Discuss |  Note




题目链接:

  http://acm.hdu.edu.cn/showproblem.php?pid=6114

题目大意:

  NxM的棋盘放最多的象棋中的车,保证下方的车一定在右侧,求方案数。

题目思路:

  【组合数】

  首先可知必须放min(n,m)个车。

  由于必须靠右侧放,所以等于无序的一个排列。

  其实就是求C(n,m)

  n<m交换n,m





/****************************************************

    Author : Coolxxx
    Copyright 2017 by Coolxxx. All rights reserved.
    BLOG : http://blog.csdn.net/u010568270

****************************************************/
#include<bits/stdc++.h>
#pragma comment(linker,"/STACK:1024000000,1024000000")
#define abs(a) ((a)>0?(a):(-(a)))
#define lowbit(a) (a&(-a))
#define sqr(a) ((a)*(a))
#define mem(a,b) memset(a,b,sizeof(a))
const double EPS=0.00001;
const int J=10;
const int MOD=1000000007;
const int MAX=0x7f7f7f7f;
const double PI=3.14159265358979323;
const int N=1004;
const int M=1004;
using namespace std;
typedef long long LL;
double anss;
LL aans;
int cas,cass;
int n,m,lll,ans;
int c[N][N];
void init()
{
    int i,j;
    c[1][0]=c[1][1]=1;
    for(i=2;i<N;i++)
    {
        c[i][0]=1;
        for(j=1;j<=i;j++)
            c[i][j]=(c[i-1][j]+c[i-1][j-1])%MOD;
    }
}
int main()
{
    #ifndef ONLINE_JUDGE
//    freopen("1.txt","r",stdin);
//    freopen("2.txt","w",stdout);
    #endif
    int i,j,k;
    int x,y,z;
//    for(scanf("%d",&cass);cass;cass--)
    init();
    for(scanf("%d",&cas),cass=1;cass<=cas;cass++)
//    while(~scanf("%d",&n))
    {
        scanf("%d%d",&n,&m);
        if(n<m)swap(n,m);
        printf("%d\n",c[n][m]);
    }
    return 0;
}
/*
//

//
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值