PAT_1009

15 篇文章 0 订阅

1009. Product of Polynomials (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
 
 
#include <vector>
#include <map>
#include <iostream>
#include <iomanip>
using namespace std;

int main(){
	int n;
	cin>>n;
	vector<pair<int,double> > cot1;
	vector<pair<int,double> > cot2;
	for(int i=1;i<=n;++i){
		int exp;
		double coe;
		cin>>exp>>coe;
		cot1.push_back(make_pair(exp,coe));
	}
	cin>>n;
	for(int i=1;i<=n;++i){
		int exp;
		double coe;
		cin>>exp>>coe;
		cot2.push_back(make_pair(exp,coe));
	}
	map<int, double> ret;
	for(vector<pair<int,double> >::size_type i = 0; i < cot1.size(); ++i){
		double coe1 = cot1[i].second;
		int exp1 = cot1[i].first;
		for(vector<pair<int,double> >::size_type j = 0; j < cot2.size(); ++j){
			int exp2 = cot2[j].first;
			double coe2 = cot2[j].second;
			int exp = exp1 +exp2;
			double coe = coe1 * coe2;
			if(coe != 0){
				if(ret.find(exp) == ret.end()){
					ret[exp] = coe;
				}
				else{
					ret[exp] += coe;
				}
			}
		}
	}

	map<int, double>::iterator it = ret.begin();
	while(it != ret.end()){
		if((*it).second == 0)
			ret.erase(it++);
		else
			++it;
	}
	cout<<fixed<<setprecision(1);
	cout<<ret.size();
	map<int, double>::reverse_iterator o = ret.rbegin();
	while(o != ret.rend()){
		cout<<" "<<(*o).first<<" "<<(*o).second;
		++o;
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值