PAT_1054

1054. The Dominant Color (20)

时间限制
100 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24
 
 
#include <iostream>
#include <vector>
using namespace std;
vector<vector<int> > cot;
vector<bool> visited;
int *id;
int *sz;
int count;
int max_length;
int over_all;

int find(int p)  
{  
	while (p != id[p])  
	{  
		// 将p节点的父节点设置为它的爷爷节点  
		id[p] = id[id[p]];  
		p = id[p];  
	}  
	return p;  
}  

void union_set(int p, int q)  
{  
	int i = find(p);  
	int j = find(q);  
	if (i == j) return;  
	// 将小树作为大树的子树  
	if (sz[i] < sz[j]) { id[i] = j; sz[j] += sz[i]; }  
	else { id[j] = i; sz[i] += sz[j]; }  
	count--;	
}  


void dfs(int source,int length){
	visited[source] = true;
	++length;
	vector<int>::iterator it = cot[source].begin();
	while(it != cot[source].end() && visited[*it])
		++it;
	if(it == cot[source].end())
	{
		if(length > max_length){
			max_length = length;
		}
		return ;
	}
	while(it != cot[source].end() && !visited[*it]){
		dfs(*it,length);
		++it;
	}
}
int main(){
	std::ios::sync_with_stdio(false);
	int N;
	cin>>N;
	count = N;
	id = new int[N];
	sz = new int[N];
	for (int i = 0; i < N; i++)  
		id[i] = i;  
	for (int i = 0; i < N; i++)  
		sz[i] = 1;

	cot.resize(N+1);
	for(int i = 1; i <N; ++i){
		int x, y;
		cin>>x>>y;
		cot[x].push_back(y);
		cot[y].push_back(x);
		union_set(x-1,y-1);
	}
	if(count == 1){
	visited.resize(N+1);
	vector<int> ret;
	for(int i = 1; i <= N; ++i){
		visited.assign(N+1,false);
		max_length = -1;
		dfs(i,0);
		if(max_length > over_all){
			over_all = max_length;
			ret.clear();
			ret.push_back(i);
		}
		else if(max_length == over_all){
			ret.push_back(i);
		}
	}

	vector<int>::iterator it = ret.begin();
	while(it != ret.end()){
		cout<<*it<<endl;
		++it;
	}
	}
	else{
		cout<<"Error: "<<count<<" components";
	}

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值