PAT:A1060. Are They Equal (17/25)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123*105 with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line "YES" if the two numbers are treated equal, and then the number in the standard form "0.d1...dN*10^k" (d1>0 unless the number is 0); or "NO" if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:
3 12300 12358.9
Sample Output 1:
YES 0.123*10^5
Sample Input 2:
3 120 128
Sample Output 2:
NO 0.120*10^3 0.128*10^3
 
 
 
 
#include <iostream>
#include <string>
#include <string.h>
using namespace std;
int N;
string A, B;
string standard(string x) {
    if(x.find('.') > 1) {
        if(x.find('.') <= N) {
            x.erase(x.find('.'));
            //return x;
        } else {
            //return x;
        }
        x = x.substr(0, N);
        return x;

    } else {
        //cout << x.find('.') << endl;
        x.erase(0, 2);
        string::iterator it = x.begin();
        while(*(it) == '0' && it != x.end()) {
            x.erase(x.begin());
            it++ ;
        }
        //return x;
        string k;
        for(int i = 0; i < N && it != x.end(); i++,it++){
            k.push_back(*(it));
        }
        return k;
    }
}
int standardN(string x, int y) {
    string::iterator it = x.begin();
    if(x.find('.') == 1){
        //x.erase(0, 2);
        it = it + 2;
        while(*(it) == '0') {
            it++;
            //x.erase(0);
            y++;
        }
        return -y;
        //return x;
    } else {
        while(*(it) != '.' && it != x.end()) {
            //x.erase(0);
            it++;
            y++;
            //cout << y << endl;
        }
        return y;
    }
    return y;
}
int main() {
    int c1 = 0, c2 = 0;
    cin >> N >> A >> B;
    c1 = standardN(A, c1);
    c2 = standardN(B, c2);
    A = standard(A);
    B = standard(B);
    if(A == B && c1 == c2) {
        cout << "YES " << "0." << A << "*10^" << c1 << endl;
    } else {
        cout << "NO " << "0." << A << "*10^" << c1 << " " << "0." << B << "*10^" << c2 <<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值