区间DP【poj3280】

Language:
Cheapest Palindrome
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 5031 Accepted: 2451

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag's contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows's ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow's ID tag and the cost of inserting or deleting each of the alphabet's characters, find the minimum cost to change the ID tag so it satisfies FJ's requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers:   N  and   M  
Line 2: This line contains exactly   M  characters which constitute the initial ID string  
Lines 3.. N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

题意:给你一个字符串,通过删除插入变成一个回文串,每种字母操作的费用不相同,问最小费用。
思路:dp[i][j]表示的是区间[i, j]内形成回文串所需要的最少的代价,这样我们就可以由一个单位字符向外扩展,状态转移方程
就应该是dp[j][i] = min(dp[j + 1][i] + cost[s[j] - 'a'], dp[j][i - 1] + cost[s[i] - 'a']),
另外如果区间的首尾字符都是一样的话,那么首尾字符全都删去还是一个回文串,这样一来再把两个代价做一个比较就可以了吧。
第一次做区间DP,首先学习思路,是从一个字符向两边扩展,所以内外循环向不同的方向加减。

dp[st][end]设为最少的代价使其成为回文。

那么有四种可转移的子问题:

1 dp[st][end-1]+add(end),即在字符串开头添加a[end],使一头一尾符合回文

2 dp[st][end-1]+del(end),删掉a[end]

3 dp[st+1][end]+add(st)....

4 dp[st+1][end]+del(st)....

显然,1和2,3和4取较小的就好了,所以某个字母的添加或删除的代价只要保留较小者,就能合二为一了。

当然,还有一个情况,就是a[st]==a[end]时,就还要考虑一个子问题:dp[st+1][end-1]。

边界情况:

很简单,所有的dp[i][j]=0, (i>=j)

dp[i][i]不说,dp[i][j]=0,(i>j)是因为只有当原来的一头一尾相等时,因为考虑子问题dp[st+1][end-1]才会使st>end,所以这也是符合回文的,代价为0.

dp重要的还是思考子问题和边界,代码写起来一般短小精悍。所以一定要思考,思考!!

 下面是代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=2020;
int cost[30];
int dp[maxn][maxn];
int main()
{
    #ifndef ONLINE_JUDGE
        freopen("in.txt","r",stdin);
    #endif

    char a[maxn];
    int n,m;
    while(cin>>n>>m)
    {
        cin>>a;
        char x;
        int s,e;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            cin>>x>>s>>e;
            cost[x-'a']=min(s,e);
        }
        for(int i=1;i<m;i++)
        {
            for(int j=i-1;j>=0;j--)
            {
                dp[j][i]=min(dp[j+1][i]+cost[a[j]-'a'],dp[j][i-1]+cost[a[i]-'a']);
                if(a[i]==a[j])
                dp[j][i]=min(dp[j][i],dp[j+1][i-1]);
            }
        }
        cout<<dp[0][m-1]<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值