POJ_2034_Anti-prime Sequences(数论+DFS)

Anti-prime Sequences
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 2620 Accepted: 1207

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

Source


题型:数论+搜索


题意:给出顺序数列的头尾m、n,求出一个排列,使得任意小于等于d长度的数的和是合数(非素数)。


分析:用DFS搜索,枚举其和。


代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<iostream>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int n,m,d;
int a[2000];
bool used[2000];
int p[12345];
void isprime(){
    memset(p,1,sizeof(p));
    p[0]=0;
    p[1]=0;
    for(int i=2;i*i<=12340+1;i++){
        if(!p[i]) continue;
        for(int j=(i<<1);j<=12340;j+=i)
            p[j]=0;
    }
}

bool judge(int x,int v){
    if(x==0) return true;
    int left=x-d+1;
    if(left<0) left=0;
    int sum=v;
    for(int i=x-1;i>=left;i--){
        sum+=a[i];
        if(p[sum]) return false;
    }
    return true;
}

bool dfs(int x){
    if(x==n-m+1) return true;
    for(int i=m;i<=n;i++){
        if(!used[i]&&judge(x,i)){
            a[x]=i;
            used[i]=true;
            if(dfs(x+1))
                return true;
            used[i]=false;
        }
    }
    return false;
}
int main(){
    isprime();
    while(scanf("%d%d%d",&m,&n,&d)){
        if(n==0&&m==0&&d==0) break;
        memset(used,0,sizeof(used));
        if(dfs(0)){
            for(int i=0;i<n-m;i++)
                printf("%d,",a[i]);
            printf("%d\n",a[n-m]);
        }
        else
            printf("No anti-prime sequence exists.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值