矩阵快速幂求斐波那契数列 poj3070

题目链接: POJ 3070

Language:
Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8738 Accepted: 6203

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


源代码

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;

const int mod = 10000;

struct matrix
{
        int a[2][2];
};

matrix mul(matrix x, matrix y)
{
        matrix res;
        res.a[0][0] = (((x.a[0][0] % mod) * (y.a[0][0] % mod)) % mod + ((x.a[0][1] % mod) * (y.a[1][0] % mod)) % mod) % mod;
        res.a[0][1] = (((x.a[0][0] % mod) * (y.a[0][1] % mod)) % mod + ((x.a[0][1] % mod) * (y.a[1][1] % mod)) % mod) % mod;
        res.a[1][0] = (((x.a[1][0] % mod) * (y.a[0][0] % mod)) % mod + ((x.a[1][1] % mod) * (y.a[1][0] % mod)) % mod) % mod;
        res.a[1][1] = (((x.a[1][0] % mod) * (y.a[0][1] % mod)) % mod + ((x.a[1][1] % mod) * (y.a[1][1] % mod)) % mod) % mod;
        return res;
}

int quickPower(matrix x, long long n)
{
        matrix res;
        memset(res.a, 0, sizeof(res.a));
        res.a[0][0] = res.a[1][1] = 1;
        while (n) {
                if (n & 1) 
                        res = mul(res, x);
                n = n >> 1;
                x = mul(x, x);
        }
        return res.a[0][1];
}

int main()
{
        long long n;
        while (scanf("%lld", &n) && n != -1) {
                if (n == 0) 
                        printf("0\n");
                else {        
                        matrix x;
                        x.a[0][0] = x.a[0][1] = x.a[1][0] = 1;
                        x.a[1][1] = 0;
                        int re = quickPower(x, n);
                        printf("%d\n", re);
                }
        }
}


在C++中,矩阵快速幂是一种高效计算斐波那契数列第n项的方法。斐波那契数列定义为:F(0)=0, F(1)=1, F(n)=F(n-1)+F(n-2)。通过矩阵形式可以表示为: ``` [ F(n) ] = [ 1 1 ]^n [ F(1) ] [ F(n-1) ] [ 1 0 ] [ F(0) ] ``` 上述矩阵的n次方可以通过快速幂算法进行高效计算。 矩阵快速幂的核心思想是利用分治法将幂的计算过程分解为更小的幂次的计算。具体步骤如下: 1. 首先定义一个矩阵,例如: ``` Matrix = [ 1 1 ] [ 1 0 ] ``` 2. 使用快速幂算法计算矩阵的n次方。快速幂算法通过不断地将指数n分解为二的幂次来减少乘法的次数。具体来说,对于矩阵M和指数n,可以按照以下方式递归或迭代计算M的n次方: - 如果n为偶数,那么M^n = (M^(n/2))^2。 - 如果n为奇数,那么M^n = M * (M^(n-1))。 3. 使用初始值构造单位矩阵,然后用快速幂计算得到的结果与初始单位矩阵相乘,最终得到的矩阵左上角的元素就是斐波那契数列第n项。 下面是使用C++实现矩阵快速幂斐波那契数列第n项的代码示例: ```cpp #include <iostream> #include <vector> using namespace std; const int MOD = 1000000007; // 定义模数,用于处理大数问题 typedef vector<vector<long long>> Matrix; // 矩阵乘法 Matrix multiply(const Matrix &a, const Matrix &b) { Matrix result(2, vector<long long>(2)); for (int i = 0; i < 2; ++i) { for (int j = 0; j < 2; ++j) { result[i][j] = 0; for (int k = 0; k < 2; ++k) { result[i][j] = (result[i][j] + a[i][k] * b[k][j]) % MOD; } } } return result; } // 矩阵快速幂 Matrix quickPow(Matrix base, long long n) { Matrix result(2, vector<long long>(2, 1)); while (n > 0) { if (n & 1) result = multiply(result, base); base = multiply(base, base); n >>= 1; } return result; } // 计算斐波那契数列第n项 int fibonacci(int n) { if (n == 0) return 0; Matrix base = {{1, 1}, {1, 0}}; Matrix result = quickPow(base, n - 1); return result[0][0]; // 返回F(n) } int main() { int n; cout << "Enter the position of the Fibonacci sequence: "; cin >> n; cout << "Fibonacci number at position " << n << " is: " << fibonacci(n) << endl; return 0; } ``` 这个程序通过定义矩阵乘法和矩阵快速幂算法,计算出斐波那契数列的第n项。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值