多校联合(4) ZZ love Cookies

题目链接:http://www.acmore.net/problem.php?id=1510

 One day, ZZ came to visit her friend LL and DD and saw that they have many cookies. The cookies are distributed into bags, As there are many cookies, ZZ decided that it’s no big deal if she steals a bag. However, she doesn’t want to her friends to quarrel because of nothing when they divide the cookies. That’s why ZZ wants to steal a bag with cookies so that the number of cookies in the remaining bags was even, that is, so that LL and DD could evenly divide into two (even 0 remaining cookies will do, just as any other even number). How many ways there are to steal exactly one cookies bag so that the total number of cookies in the remaining bags was even?

Input

The first line contains the only integer n (1 ≤ n ≤ 1000) — the number of cookie bags Anna and Maria have. The second line contains n integers ai (1 ≤ ai ≤ 1000) — the number of cookies in the i-th bag.

Output

Print in the only line the only number — the sought number of ways. If there are no such ways print 0.

Sample Input

1
1
10
1 2 2 3 4 4 4 2 2 2

Sample Output

1
8

 

题目是一个简单的题目,只要统计奇数和偶数的个数,再把所有的数加起来SUM,看是奇数或偶数。

AC代码:

#include<iostream> 
using namespace std; 
int main() 
{ 
    int n,i; 
    int q[1008]; 
    while(cin>>n && n) 
    { 
        int sum=0; 
        int ant=0,ant1=0; 
        for(i=0;i<n;i++) 
        { 
            cin>>q[i]; 
            sum+=q[i]; 
            if(q[i]%2 == 0) 
              ant++; 
            else
              ant1++; 
        } 
        if(sum%2 == 0) 
          cout<<ant<<endl; 
        else
          cout<<ant1<<endl; 
    } 
    return 0; 
} 


路途中。。。。。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值