HihoCoder#1082: 然而沼跃鱼早就看穿了一切

#1082 : 然而沼跃鱼早就看穿了一切

时间限制:1000ms

单点时限:1000ms

内存限制:256MB

描述

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx”

输入

输入包括多行。

每行是一个字符串,长度不超过200

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入

The Marshtomp has seen it all before.
marshTomp is beaten by fjxmlhx!
AmarshtompB

样例输出

The fjxmlhx has seen it all before.
fjxmlhx is beaten by fjxmlhx!
AfjxmlhxB

一开始觉得很简单,就是一个简单的字符串替换,结果居然还是WA了几次。。。无语了。

二点总结:

1.   每次替换之后要找到替换后的位置

2.   没有marshtomp的情形也要考虑到啊


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
using namespace std;


string tihuan(string s,int count)
{ 
	return s.substr(0,count)+"fjxmlhx"+s.substr(count+9);
}

int main()
{
	string s;
	while(getline(cin,s))
	{
		int count;
		string result;
		int len = s.length()-8;
		result = s;
		for(count=0;count<len;count++)
		{
			if((s[count]=='m'||s[count]=='M')
				&&(s[count+1]=='a'||s[count+1]=='A')
				&&(s[count+2]=='r'||s[count+2]=='R')
				&&(s[count+3]=='s'||s[count+3]=='S')
				&&(s[count+4]=='h'||s[count+4]=='H')
				&&(s[count+5]=='t'||s[count+5]=='T')
				&&(s[count+6]=='o'||s[count+6]=='O')
				&&(s[count+7]=='m'||s[count+7]=='M')
				&&(s[count+8]=='p'||s[count+8]=='P'))
			    {
					result=tihuan(s,count);
			        s=result;
					count =count+6;
			}
		}
		cout<<result<<endl;
	}
	
	system("pause");
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值