POJ 3254:Corn Fields

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9295 Accepted: 4940

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

没见过比这个还标准的状态dp了,搞一下骨牌覆盖的那种题会瞬间有做这题的思路的。一开始没想到result数组里面的数值可能会超,WA了几次,最后发现结果有负数改过来了就AC了。


代码:

#include <iostream>
#include <vector>
#include <string>
#include <cstring>
#include <algorithm>
#pragma warning(disable:4996)
using namespace std;

int n,m;
int state[15][15];
long long result[15][(1<<13)-1];

bool pend_ok(int pend,int row[])
{
	int i;
	for(i=n;i>=1;i--)
	{
		int wei =pend & 1;
		if(row[i]== 0 &&wei==1)//11001
		{
			return false;
		}

		pend = pend>>1;
		
		int wei2=pend&1;
		
		if(wei&&wei2)
			return false;
	}
	return true;
}

bool pend(int j,int k )
{
	int i;
	for(i=1;i<=n;i++)
	{
		int wei1 = j&1;
		int wei2 = k&1;

		if(wei1==1&&wei2==1)
		{
			return false;
		}
		j=j>>1;
		k=k>>1;
	}
	return true;
}

int main()
{	
	int i,j,k;
	cin>>m>>n;

	for(i=1;i<=m;i++)
	{
		for(j=1;j<=n;j++)
		{
			scanf_s("%d",&state[i][j]);
		}
	}

	int n1=(1<<n)-1;

	memset(result,0,sizeof(result));

	for(j=0;j<=n1;j++)
	{
		if(pend_ok(j,state[1]))
		{
			result[1][j]=1;
		}
	}

	for(i=2;i<=m;i++)
	{
		for(j=0;j<=n1;j++)
		{
			for(k=0;k<=n1;k++)
			{
				if(pend_ok(j,state[i])&&pend(j,k))
				{
					result[i][j] += result[i-1][k];
					if(result[i][j]>100000000)//result的值可能会超过,这里要先过滤一下!!!(之前没过滤导致wrong)
						result[i][j]=result[i][j]-100000000;
				}
			}
		}
	}
	long long max=0;
	for(j=0;j<=n1;j++)
	{
		max +=result[m][j];
		max=max%100000000;
	}
	
	cout<<max%100000000<<endl;

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值