欧拉回路 fzu Problem 2112 Tickets

http://acm.fzu.edu.cn/problem.php?pid=2112

Problem 2112 Tickets

Accept: 229    Submit: 406
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

You have won a collection of tickets on luxury cruisers. Each ticket can be used only once, but can be used in either direction between the 2 different cities printed on the ticket. Your prize gives you free airfare to any city to start your cruising, and free airfare back home from wherever you finish your cruising.

You love to sail and don't want to waste any of your free tickets. How many additional tickets would you have to buy so that your cruise can use all of your tickets?

Now giving the free tickets you have won. Please compute the smallest number of additional tickets that can be purchased to allow you to use all of your free tickets.

 Input

There is one integer T (T≤100) in the first line of the input.

Then T cases, for any case, the first line contains 2 integers n, m (1≤n, m≤100,000). n indicates the identifier of the cities are between 1 and n, inclusive. m indicates the tickets you have won.

Then following m lines, each line contains two integers u and v (1≤u, v≤n), indicates the 2 cities printed on your tickets, respectively.

 Output

For each test case, output an integer in a single line, indicates the smallest number of additional tickets you need to buy.

 Sample Input

35 31 31 24 56 51 31 21 61 51 43 21 21 2

 Sample Output

120

 Source

“高教社杯”第三届福建省大学生程序设计竞赛

离散课上学过,欧拉通路 要么没有odd顶点,要么两个odd顶点,所以处理下就行了


#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdlib>
#include <cmath>

using namespace std;
#define MAXN 100005

int degree[MAXN];

int main()
{
    int ncase,u,v,n,m,ans;

    scanf("%d",&ncase);

    while(ncase--)
    {
        memset(degree,0,sizeof(degree));
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&u,&v);
            degree[u]++;
            degree[v]++;
        }
        ans=0;
        for(int i=0;i<=n;i++)
            ans+=degree[i]%2;
        ans=(ans-2)/2;
        ans<0?printf("0\n"):printf("%d\n",ans);
    }
    return 0;

}




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值