POJ1759Garland题解

题目

链接

http://poj.org/problem?id=1759

字面描述

Garland
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4708 Accepted: 1976
Description

The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp’s size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:

H1 = A
Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N
HN = B
Hi >= 0, for all 1 <= i <= N

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75.
Input

The input file consists of a single line with two numbers N and A separated by a space. N (3 <= N <= 1000) is an integer representing the number of lamps in the garland, A (10 <= A <= 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.
Output

Write to the output file the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.
Sample Input

692 532.81
Sample Output

446113.34
Source

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-nFgyD5Tk-1660137569306)(http://poj.org/images/1759_1.jpg#pic_center)]

思路

二分第二个灯的高度,根据a[i]=(a[i-1]+a[i+1])/2-1;=>a[i+1]=2a[i]-a[i-1]+2;=>h[i]=2h[i-1]-h[i-2]+2;往后退,若有接触地面则二分,否则记录答案再二分

重点

建议整个eps=1e-7,对精度进行优化

代码实现

#include<cstdio>
using namespace std;

const int maxn=1e3+10;
const double eps=1e-7;
int n;
double ll,ans; 
double a[maxn];
//模拟是否接触地面
inline bool check(double mid){
	a[2]=mid;
	for(int i=3;i<=n;i++){
		a[i]=2*a[i-1]-a[i-2]+2;
		if(a[i]<eps)return false;
	}
	ans=a[n];
	return true;
}
int main(){
	scanf("%d%lf",&n,&ll);
	a[1]=ll;
	double l=0.0,r=ll;
	//二分
	while(r-l>eps){
		double mid=(l+r)/2;
		if(!check(mid))l=mid;
		else r=mid;
	}
	printf("%.2lf\n",ans);
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_Yxz_

我只是一名ssfoier

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值