UVa 1555 Garland 解题报告(推导)

1555 - Garland

Time limit: 3.000 seconds

Sample garland pictureThe New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp's size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:

  • H1 = A
  • Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N
  • HN = B
  • Hi ≥ 0, for all 1 ≤ i ≤ N

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75.

Input 

The input file consists of several datasets. Each datasets contains a single line with two numbers N and A separated by a space. N (3 ≤ N ≤ 1000) is an integer representing the number of lamps in the garland, A (10 ≤ A ≤ 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.

Output 

For each dataset, write to the output the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.

Sample Input 

692 532.81

Sample Output 

446113.34

    解题报告: 简单推理。

    由题意得,a[i] = (a[i-1]+a[i+1])/2 - 1.

    移项,得:a[i+1]-a[i] = a[i] - a[i-1] + 2.

    设:f[i] = a[i] - a[i-1],得f[i] = f[i-1] + 2.

    a[i+1] = a[i] + f[i+1].

    f[i]是等差数列,题目也就变成了类似于求等差数列的和了。最后注意如果在n-1次下降中都没有到0,可以直接将答案置0。

    代码如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <queue>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <iomanip>
using namespace std;
#define ff(i, n) for(int i=0;i<(n);i++)
#define fff(i, n, m) for(int i=(n);i<=(m);i++)
#define dff(i, n, m) for(int i=(n);i>=(m);i--)
typedef long long LL;
typedef unsigned long long ULL;
void work();
int main()
{
#ifdef ACM
    freopen("in.txt", "r", stdin);
#endif // ACM
    work();
}

/***************************************************/

void work()
{
    double n;
    double a;
    while(scanf("%lf%lf", &n, &a) == 2)
    {
        double m = floor(sqrt(a));
        if(m*(m+1) <= a) m++;
        double h = (a - m*(m-1))/m;

        if(m >= n-1)
            a = 0;
        else
            a += (n-1)*(n-h-m*2);

        printf("%.2lf\n", a);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值